Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Using HFSS on Supercomputers using PBS

Status
Not open for further replies.

kritia

Newbie level 2
Joined
Sep 2, 2014
Messages
2
Helped
0
Reputation
0
Reaction score
0
Trophy points
1
Activity points
28
Hi,

I am trying to submit an HPC job for HFSS 16.1 using a pbs job. However, it only seems to be using one node and is insanely slow. Can somebody please look into my pbs job below and let me know what I am doing wrong.

It needs 800GB RAM at a minimum


Code C - [expand]
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
#!/bin/bash -l
 
#PBS -N SRR_jcho
#PBS -j oe
 
#PBS -l walltime=24:00:00,nodes=4:ppn=16,mem=1000gb
#PBS -m abe
#PBS -M [email]agarw071@umn.edu[/email]
 
 
module load hfss
 
export OptFile=${PBS_O_WORKDIR}/Options.txt
export ANSYSEM_JOB_ID=${PBS_JOBID}
export ANSYSEM_HOST_FILE=$PBS_NODEFILE
export LINUX_SSH_BINARY_PATH=/usr/bin
export ANSYSEM_LINUX_HPC_UTILS=/opt/software/AnsysEM/15.0/AnsysEM15.0/Linux64/schedulers/utils
 
cd ${PBS_O_WORKDIR}
    # mkdir -p ${PBS_O_WORKDIR}/scratch
 
echo creating batch options list
echo \$begin \'Config\' > ${OptFile}
    echo \'HFSS/NumCoresPerDistributedTask\'=${PBS_NUM_PPN} >> ${OptFile}
    echo \'HFSS/HPCLicenseType\'=\'Pool\' >> ${OptFile}
echo \'HFSS/SolveAdaptiveOnly\'=0 >> ${OptFile}
    echo \'HFSS/MPIVendor\'= \'Intel\' >> ${OptFile}
echo \'HFSS-IE/NumCoresPerDistributedTask\'=${PBS_NUM_PPN}  >> ${OptFile}
echo \'HFSS-IE/HPCLicenseType\'=\'Pool\' >> ${OptFile}
    echo \'HFSS-IE/SolveAdaptiveOnly\'=0 >> ${OptFile}
echo \'HFSS-IE/MPIVendor\'=\'Intel\' >> ${OptFile}
    # echo \'tempdirectory\'=\'${PBS_O_WORKDIR}/scratch\' >> ${OptFile}
    echo \$end \'Config\' >> ${OptFile}
chmod 777 ${OptFile}
 
hfss -Ng -monitor -distributed -batchoptions "HFSS/HPCLicenseType=pool" -BatchSolve vacuum_gap_10nm.hfss

 
Last edited by a moderator:

PlanarMetamaterials

Advanced Member level 4
Joined
Jun 13, 2012
Messages
1,174
Helped
359
Reputation
718
Reaction score
313
Trophy points
1,363
Location
Edmonton, Canada
Activity points
7,796
Hi kritia,

I was trying something similar not long ago, and was getting the same results. It turned out that the meshing process took upwards of 24 hrs, and this process only used one node.

What I ended up doing is pre-meshing the simulation on a desktop computer and then transferring the simulation data over to the supercomputer to do the actual adaptive passes.

This was with a previous version of HFSS (12, I think), so as a disclaimer they may have fixed this and your problem could be entirely unrelated.

Good Luck!
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top