Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

RH Linux 7.3 + Ment0r HDL Designer = HELP!

Status
Not open for further replies.

danno

Junior Member level 3
Joined
Dec 20, 2001
Messages
28
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
173
could not create fontset for font

I don't know if this is a RH Linux 7.3 problem, or an
HDL designer problem, but when HDL designer starts up
I get the following error message:

Error:Could not create fontset for font
'-adobe-helvetica-bold-r-normal--14-100-100-100-p-82-ISO8859-1'
The following characters can not be drawn with this font
ISO8859-15

I'm sure this font is installed because I can select in the
Gnome Font Selector.

Anyone have a suggestion???

Thanks,

-danno
 

danno

Junior Member level 3
Joined
Dec 20, 2001
Messages
28
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
173
hdl designer linux

Any ideas??

Anybody??

-danno
 

mhmhmh

Full Member level 3
Joined
Oct 21, 2001
Messages
158
Helped
7
Reputation
14
Reaction score
4
Trophy points
1,298
Activity points
812
error:could not create fontset for font

I have the same problem in RH 7.2.
 

danno

Junior Member level 3
Joined
Dec 20, 2001
Messages
28
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
173
error: could not create fontset for font

Hmm, really!?

I wonder if it's an issue with HDL Des1gner, then.

In my case, the program _seems_ to run fine, and the
menu items, text, etc. look OK. I just hate to see those
error messages...

Does RH 6.2 use the xfs font server to manage fonts,
or is the FontPath hard-coded in the X-windows
configuration file?? I'm thinking of disabling xfs and
letting X manage the fonts directly to see if that helps...

-danno
 

heedless

Newbie level 3
Joined
Jan 4, 2006
Messages
4
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,283
Activity points
1,302
mentor hdl designer how to run under linux

Hi,

Did you solve this eventually?


I'm having the same problem with Gentoo and HDL Designer 2006.1


I've also noticed there's a support bulliten on Mentor's Website, but i'm not able to access it:

"TechNote mg25665: HDL Designer: Error when invoking tool on Linux RedHat 8.0 or Fedora"
"Symptoms Error when invoking HDL Designer on Linux RedHat 8.0 or Fedora Error: Could not create FontSet for font '-adobe-helvetica-medium-r-normal-*-12-*-*-*-*-*-*'. The following character sets cannot be drawn with this font: Solutions"

http://www.mentor.com/supportnet/member/technotes/public/enhancement/mg25665.html

Does someone have a mentor registration?
 

danno

Junior Member level 3
Joined
Dec 20, 2001
Messages
28
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
173
how to use hdl designer on linux

No, sorry. I never found a solution to the problem.
 

heedless

Newbie level 3
Joined
Jan 4, 2006
Messages
4
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,283
Activity points
1,302
hdl designer help

Hopefully, Today I'll have a chance to visit someone with a mentor registration... So stay tuned!
 

heedless

Newbie level 3
Joined
Jan 4, 2006
Messages
4
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,283
Activity points
1,302
fedora adobe-helvetica-bold-r-normal--12

Okay,
Attached is what I found from Mentor's SupportNet Website.

It didn't help me much... but I though you might wanna give it a try.
 

heedless

Newbie level 3
Joined
Jan 4, 2006
Messages
4
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,283
Activity points
1,302
mentor hdl author linux

Just Solved it!
(on gentoo)



I only had to create symlinks in my X11R6 Directory:

cd /usr/X11R6/lib/X11/
ln -s /usr/share/X11/XKeysymDB XKeysymDB
ln -s /usr/share/X11/locale/ locale

and it worked!


good Luck!
 

Pano

Newbie level 1
Joined
Jan 19, 2007
Messages
1
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,284
adobe-helvetica-medium fedora 11

heedless!! Thanks!! I couldn't figure this out at all, but your solution works for me!

Pano
 

Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top