Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

[SOLVED] problem with 2 terminal resistor

Status
Not open for further replies.

polygon pusher

Newbie level 5
Joined
Sep 15, 2010
Messages
10
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,349
Hi,

I have a 2 terminal resistor placed in the schematic which has it's bulk connected to sub! (I can't see how it is set in the menu!)
The resistor is placed as a tie low with one end connected to vss.

When I lay it out the LVS complains that my Sub! is shorted to vss. Is there anyway to set the 2 terminal resistors bulk to be tied to vss in the schematic to stop the error occuring??

I am using Cadence schematic and Layout XL

Thanks
 

cameo_2007

Advanced Member level 3
Joined
Mar 15, 2007
Messages
752
Helped
70
Reputation
142
Reaction score
44
Trophy points
1,308
Location
12°58' N77°38'E
Activity points
5,046
there are a few unknown terms: 2-terminal resistor, bulk, sub, tie, LVS :-o could you please come again.

Note: I am not sure whether it is only me who is not aware of these terms :???: pls ignore in that case.
 

jimito13

Advanced Member level 1
Joined
Nov 17, 2008
Messages
470
Helped
130
Reputation
262
Reaction score
122
Trophy points
1,323
Location
Greece
Activity points
4,929
From the terms you use i suppose you work with an IBM pdk.Right?Under this assumption,you correctly connect the third (middle) terminal of the resistor to sub!.(What do you mean by saying I can't see how it is set in the menu! ?).Do you have subc device in your schematic and layout?I suspect that the problem is there.

Please give me a snapshot of the schematic & layout of the resistor and a snapshot of the exact LVS error.

A final remark : When you ask for such kind of solutions you should always say the CAD tool version,the pdk's fab and version,the device type that has the problem (e.g. mimcap) and if possible give screenshots with the problem to appear clearly.Only in this way you will get a detailed and direct answer.
 
Last edited:

yoshrini

Newbie level 2
Joined
Feb 20, 2011
Messages
2
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,283
Activity points
1,291
One more thing you can check is the type of symbol being used in schematic for the resistor.
If its a 2 terminal symbol or three terminal symbol.

For 2 terminal symbol you can enter the sub terminal name in form itself, while in 3 terminal symbol ( like symbol3T ) you can add extra wire in schematic for substrate node and connect to required substrate potential.
 

Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top