Continue to Site

Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Problem in XC3S400 FPGA configuration through XCF04s

Status
Not open for further replies.

omidsht

Member level 2
Joined
Dec 24, 2007
Messages
43
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Activity points
1,556
Hi
I have made a pcb board of the attached schematic, but I it has a problem. When I
program the FPGA (xc3s400) solely through jtag (Platform cable usb II) the FPGA is program and okay, also when I
program the FLASH (xcf04s) solely it is programmed as well (as impact says), but the problem is this that after programming the FLAHS,
the FPGA is not configured and programmed by FLASH through master serial mode! as I check the DONE pin of FPGA, it never comes high ( it is low, indicating that FPGA has not
been configured by FLASH), also the CCLK pin of FPGA continues to pulsing the CLK pin of FLASH for ever!
I checked every thing but I couldnt find out what is the problem . I would be very thankfull if somebody can help me solving this problem
thanks in advance
Regards
omidsht[at]yahoo[dot]com
 

Attachments

  • xc3s400.pdf
    455.8 KB · Views: 77

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Back
Top