Continue to Site

Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Need help for load pull analysis of PA using ADS2022

narayani

Full Member level 2
Joined
Aug 15, 2014
Messages
121
Helped
0
Reputation
0
Reaction score
1
Trophy points
1,298
Activity points
2,271
I want to do Load Pull Analysis of MMIC Power Amplifier. I have listened Anuragh Bhargav's RF Design-13: Getting Started with Load Pull Simulations (Link for the same is attached below). After listining the same I started designing PA using Keysight Technologies ADS 2022 by following the steps from the same RF Design Tutorial -13 and I followed exactly. When I simulated Load Pull Analysis, I am getting blank graphs. Someone can guide me how to plot load pull analysis. Below I have attached the screen shots which I have taken from RF Design-13 and obtained results.
Desired Outputs graphs are as follows:
1. Desired_Ouput_Graphs
2. Desired_Ouput_Graphs_1
3. Desired_Ouput_Graphs_2
4. Desired_Ouput_Graphs_3
5. Schematic_1
Obtained Outputs are as follows:
1. Schematic_Drawn_Using_ADS2022
2. Obtaind_Output_Graphs

 

Attachments

  • Desired_Output_Graphs_1.jpg
    Desired_Output_Graphs_1.jpg
    104.5 KB · Views: 99
  • Desired_Output_Graphs_2.jpg
    Desired_Output_Graphs_2.jpg
    201.9 KB · Views: 95
  • Desired_Output_Graphs_3.jpg
    Desired_Output_Graphs_3.jpg
    96.1 KB · Views: 102
  • Schematic_1.jpg
    Schematic_1.jpg
    289.6 KB · Views: 112
  • Schematic_Drawn_Using_ADS_2022.jpg
    Schematic_Drawn_Using_ADS_2022.jpg
    106.8 KB · Views: 97
  • Obtained_Output_Graphs.jpg
    Obtained_Output_Graphs.jpg
    187.6 KB · Views: 96
  • Desired_Output_Graphs.jpg
    Desired_Output_Graphs.jpg
    123.4 KB · Views: 101
Any error message ?? Check the datasets' names.There are multiple simulation controller and each one may create a particular name.
You can also use "Load Pull Design Guide" instead of this, there are many Templates and Test Benches to be used.
 
One difference: in the PAE instance, the tutorial schematic defines PAE, but you defined PAE1.View attachment 184032
I have changed PAE option as you rightly pointed out. But there is no change in the output graph. I have attached the same below.
--- Updated ---

I have changed PAE option as you rightly pointed out. But there is no change in the output graph. I have attached the same below.
I am trying also using Load Pull Deign template.
 

Attachments

  • Schematic_PAE_Changed.jpg
    Schematic_PAE_Changed.jpg
    311.2 KB · Views: 85
  • Modified_PAE_Output.jpg
    Modified_PAE_Output.jpg
    182 KB · Views: 84
Last edited:
There is no magic solution, you need to troubleshoot this step by step.

If you click on the red equation (=error) in ADS data display, you will see a message what each problem is. It might be something simple as a typo.
 
There is no magic solution, you need to troubleshoot this step by step.

If you click on the red equation (=error) in ADS data display, you will see a message what each problem is. It might be something simple as a typo.
I am getting output power when we use load pull analysis template. I have some doubts. In the template, they have shown only single frequency (RF_Freq= 1000 MHz). My doubt is how to sweep the values from 2 to 4 GHz and get output power from the same. Because I want to design PA from 2 to 4 GHz and get the output power for the same range.
One more doubt is can we use entire circuit with input and output matching circuit or simply use transistor to get the output power and PAE. Is it enough.
Below I have attached the Load Pul Anslysis from ADS Cook.
 

Attachments

  • Load_Pull_Analysis_Document.pdf
    302.1 KB · Views: 266
I am getting output power when we use load pull analysis template. I have some doubts. In the template, they have shown only single frequency (RF_Freq= 1000 MHz). My doubt is how to sweep the values from 2 to 4 GHz and get output power from the same. Because I want to design PA from 2 to 4 GHz and get the output power for the same range.
One more doubt is can we use entire circuit with input and output matching circuit or simply use transistor to get the output power and PAE. Is it enough.
Below I have attached the Load Pul Anslysis from ADS Cook.
It's a little bit tough task. Optimum Load Impedance along this band will NOT be same for Constant Power. They might be closer even very close but not same. You have to choose an appropriate and compromised point to get "almost" same power level.
This statement is also valid for Input Matching Circuit. There won't-possibly- be an unique circuit but closer matching circuit.
 
This statement is also valid for Input Matching Circuit. There won't-possibly- be an unique circuit but closer matching circuit.
Can't we have exact input matching and output matching circuit at the input and output of PA respectively whatever we are using at the input and output matching circuit for simulation purpose.
I have few doubts in the Load Pull Instrument simulation. I have attached below Load_Pull_Instrument_1 and Load_Pull_Instrument_2 screen shots.
1. In Load_Pull_Instrument_1 screen shot, I have shown some parameters such as S_imag_min = -0.3, S_imag_max = 0.4, etc. How to set values to these parameters or let it be as it is default values and what do you mean by these parameters.
2. In Load_Pull_Instrument_2 screen shot, I have shown some parameters in the Square and Round box. How to set values to these parameters or let it be as it is default values and what do you mean by these parameters.
I am getting confused by observing these parameters. Please clarify these doubts.
 

Attachments

  • Load_Pull_Instrument_1.jpg
    Load_Pull_Instrument_1.jpg
    63.2 KB · Views: 73
  • Load_Pull_Instrument_2.jpg
    Load_Pull_Instrument_2.jpg
    184.4 KB · Views: 70
Can't we have exact input matching and output matching circuit at the input and output of PA respectively whatever we are using at the input and output matching circuit for simulation purpose.
I have few doubts in the Load Pull Instrument simulation. I have attached below Load_Pull_Instrument_1 and Load_Pull_Instrument_2 screen shots.
1. In Load_Pull_Instrument_1 screen shot, I have shown some parameters such as S_imag_min = -0.3, S_imag_max = 0.4, etc. How to set values to these parameters or let it be as it is default values and what do you mean by these parameters.
2. In Load_Pull_Instrument_2 screen shot, I have shown some parameters in the Square and Round box. How to set values to these parameters or let it be as it is default values and what do you mean by these parameters.
I am getting confused by observing these parameters. Please clarify these doubts.
They are variables which are used in equations page.
These limits restrict the sweeping and they can be easily modified in regard of your purpose.
For instance you can sweep whole Smith Chart at the beginning to find coarsely optimum values then shrink the region by restrict the limits to find precisely the optimum value.
That's the purpose.
 
Sorry for trouble. I have tried to get good Output Power and PAE for higher frequency at 27 GHz using 0.15um GaN HEMT transistor. When I did load pull analysis in this frequency. I am getting too low Output Power and Power Added Analysis (PAE) (Which graphs I have attached below).
What should be done to get Output Power and Power Added Efficiency (PAE) more than 5 Watts and 35 %.
 

Attachments

  • Ka_Band_Output_Power_Graphs.png
    Ka_Band_Output_Power_Graphs.png
    142.7 KB · Views: 80
  • Ka_Band_Load_Pull_Analysis_Schematic.jpg
    Ka_Band_Load_Pull_Analysis_Schematic.jpg
    267.7 KB · Views: 89
Didi you see the Power Gain @ max. Power or max. PAE ??
Gp=0.3 dB !! ;)
Something is not going on well my friend. Work on optimization ..

Hint: Sweep the Load along whole Smith Chart coarsely/roughly then find a good region that satisfies you then shrink this region by changing the equation limits that we have already talked about.( Center, max. real and imag. parts )
After that make additional Load Pull simulation with finer steps.
 
I am getting error during parameter sweeping Load Pull Simulation. I have included parameter sweep varaibles and swept variables though I changed SweepVar in both Load Pull and Load Pull Instrument analysis. How to remove this error. Guide me. I have attached error messages below.
 

Attachments

  • Error_Showing.jpg
    Error_Showing.jpg
    103.6 KB · Views: 75
  • Laod_Pull_Analysis.jpg
    Laod_Pull_Analysis.jpg
    144.5 KB · Views: 75
  • Load_Pull_Instrument_1.jpg
    Load_Pull_Instrument_1.jpg
    401 KB · Views: 72
I am getting error during parameter sweeping Load Pull Simulation. I have included parameter sweep varaibles and swept variables though I changed SweepVar in both Load Pull and Load Pull Instrument analysis. How to remove this error. Guide me. I have attached error messages below.
Some can help me to remove this error.
 

Attachments

  • Error_Showing.jpg
    Error_Showing.jpg
    103.6 KB · Views: 68
SweepVar must have a default value. Also it might be a Internal ADS Variable (not sure)
Simply ;
Assign a Default Value for variable frequency like that.

LoadPullFrequency=26e9

RF_Freq=LoadPullFrequency in X1 (without unit)
Start=26e9 and Stop=32e9 and Step=500e6 in Sweep1
 
SweepVar must have a default value. Also it might be a Internal ADS Variable (not sure)
Simply ;
Assign a Default Value for variable frequency like that.

LoadPullFrequency=26e9

RF_Freq=LoadPullFrequency in X1 (without unit)
Start=26e9 and Stop=32e9 and Step=500e6 in Sweep1
As you said, I made changes. I am getting same error as before how I was getting. I tried all options, I could not eliminate errors. Guide me someone, how to overcome this difficulty. I have also attached below relevant schematic screen shots.
 

Attachments

  • HB1Tone_LoadPull_1.jpg
    HB1Tone_LoadPull_1.jpg
    321.7 KB · Views: 65
  • HB1Tone_LoadPull.jpg
    HB1Tone_LoadPull.jpg
    169.2 KB · Views: 64
  • Error_Message.jpg
    Error_Message.jpg
    169.4 KB · Views: 76
Perhaps you have to copy VAR1 on the top level into Load_Pull_Instrument1 level. It might not see the VAR1.
After including VAR1 in the top level also, I am once again getting error.
 

Attachments

  • Error_Message.jpg
    Error_Message.jpg
    264.3 KB · Views: 77
  • HB1_Analysis.jpg
    HB1_Analysis.jpg
    511.7 KB · Views: 66
  • Load_Pull_Controll_Analysis.jpg
    Load_Pull_Controll_Analysis.jpg
    593.3 KB · Views: 71
I am getting one more trouble while simulating Constant Power Delivered Load Pull. When I press execution button , execution is not at all terminating immediately. It keeps executing and it is taking more than 2 hour and also will not come out of the execution.
Guide me how to come out of the execution after few minutes. If I stop the execution at the middle, it is not showing any output and it is showing blank output.
 

Attachments

  • Constant_Power_Delivered_Schematic.jpg
    Constant_Power_Delivered_Schematic.jpg
    241 KB · Views: 69
  • Error_Message.jpg
    Error_Message.jpg
    379.9 KB · Views: 69
  • Showing_Blank_Output.jpg
    Showing_Blank_Output.jpg
    223.3 KB · Views: 64

LaTeX Commands Quick-Menu:

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Back
Top