Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

Dot Matrix led display not same brightness.

Status
Not open for further replies.

maniac84

Full Member level 6
Joined
Mar 4, 2012
Messages
337
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,298
Activity points
3,661
Hi guys, I have a 64x16 pixel dot matrix led display. It is build out from 16 pieces of 8x8 pixel dot matrix led.
But now the problem is, when I show some characters, the brightness of 1st row is brighter than the other 15 rows. Do you guys have an idea what's wrong with it? Is it firmware problem or it's hardware problem? I don't have any direction on how to troubleshoot this.
 

wavelet1208

Member level 2
Joined
Oct 28, 2011
Messages
52
Helped
11
Reputation
22
Reaction score
11
Trophy points
1,288
Activity points
1,511
I think maybe it's firmware problem,can you show your code?
 

maniac84

Full Member level 6
Joined
Mar 4, 2012
Messages
337
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,298
Activity points
3,661
I've investigate further. When there are more dot lighten up on a row, that row will become less bright. If there is less dot lighten up on a row, that row will become brighter.
So, I don't think it's firmware problem. It is insufficient power?
 

sequel

Member level 4
Joined
Oct 27, 2012
Messages
76
Helped
8
Reputation
16
Reaction score
7
Trophy points
1,288
Location
Nigeria
Activity points
1,753
just like wavelet1208 pointed out; post your design here so that proper guidance will be given.

it may be a firmware or hardware problem....
sequel
 

maniac84

Full Member level 6
Joined
Mar 4, 2012
Messages
337
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,298
Activity points
3,661
I don't have the coding nor the schematic. My fren just past me this display.
Just want you guys opinion, generally what's wrong with the dot matrix display if I have a problem like this?
 

sequel

Member level 4
Joined
Oct 27, 2012
Messages
76
Helped
8
Reputation
16
Reaction score
7
Trophy points
1,288
Location
Nigeria
Activity points
1,753
can you take a snap shot of the circuit and also the matrix
or better still the chips you have there in the circuit
 

drbizzarow

Advanced Member level 1
Joined
May 24, 2006
Messages
416
Helped
25
Reputation
50
Reaction score
15
Trophy points
1,298
Activity points
3,647
seems to be scanning code error
 

maniac84

Full Member level 6
Joined
Mar 4, 2012
Messages
337
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,298
Activity points
3,661
I've found out that it uses the MBI5025 driver ic for the column data and the 74HC4094 ic for the row data. Is the current constant for each row?
If for example there's constant current 50mA for each row, then I think the brightness of using 50mA to light up 10 dots on a row, won't be the same with the brightness of using 50mA to light up 30 dots on a row. Am I right?

- - - Updated - - -

I don't think it's firmware problem. Because when there is less dot to turn on, the dots will be brighter. When there is more dot to turn on, the dots will be dimmer. Am I right?
 
Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top