Continue to Site

Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Can you help me with this error in IC610?

Status
Not open for further replies.

sutapanaki

Advanced Member level 4
Joined
Nov 2, 2001
Messages
1,346
Helped
0
Reputation
1,046
Reaction score
483
Trophy points
1,363
Location
US
Activity points
11,148
Hi,

I'm trying to plot the gds parameter of a MOS transistor during DC
sweep. I have done "save M:eek:ppoint" and simulation goes ok. Then from
results browser I'm able to plot gds vs. the sweep parameter in
wavescan. What I wanted to do next was to input this waveform in
calculator, do some processing, namely namely get the reciprocal of it (1/gds) and plot again. When
I tried to plot it from calculator though, I got the following error:

- Warning -
<Calculator>
Evaluation error(ERROR : ("quotient" 0 t nil ("*Error* quotient:
can't handle (1 / nil)"))). Expression: 1/getData("/MN:gds" ?
resultsDir "/home/simulation/HW4_pr3/spectre/schematic" ?result "dc-
dc")

- Warning -
<Calculator>
Evaluation error(Unknown scalar data type: nil). Expression: getData
("/MN:gds" ?result "dc-dc")

As far as I understand it, it says that the denominator is 0 (nil).
However, I just got the waveform from wavescan, so it can't be nil. Even if I
try to put it in the calculator from wavescan and immediately plot back from there, without any
processing it still gives the same error. I tried doing the same
procedure on a regular AC analysis, just plotting node voltages from
results browser and from calculator. It works without a problem. Can
anyone help, please? Thanks
 

I refuse to use the wavescan calculator because it seems
to lack many of the convenient built-in functions the older
one provided.

But, in debugging plot problems, I have found it useful
to use the "old" calculator to select OP() result and just
Print it, first. If you can print it, you can plot it, but you
can run just a single point (not sweep) and eliminate the
axis- or sweep-relayed issues and deal with the calculator
syntax / availability of results by themselves.

I have not seen this "dc-dc" before.

It may be that you have to either pick results from the
"dc sweep" (vs, is in the old calculator), or step the params
using Parametric Analsys instead of trying to sweep. A swept
DC analysis may not produce an OP (or recognized as such)
result, to pick from while PA would produce a whole rack
of them.
 

In fact I have resolved the problem. It boils down to wrong mapping between netlist notation and wavescan notation. When you import op results into the calculator from wavwscan they appears as 1/getData("/MN:gds" etc. If the / is removed like in 1/getData("MN:gds" the thing works again. Evidently, this happens only for this kind of analysis.
 

Can you be more specific with the solution you found for this??I experience the same problem.I would appreciate your helpful answer.Thanks in advance :)
 

Well, it is just as I described it before. When you import into calculator from wavescan it appears as 1/getData("/MN:gds"......... To fix it I just removed the / in front of MN. That's all.
 

The solution you proposed was pretty clear to your old post,but i asked again because in IC6131 wavescan there is not any "/" at the point of the expression you indicate.Anyway,i relosved my problem by doing what i am going to describe.In my design i have a transistor named T1+.Probably wavescan has a bug and understands + as an opetaror and not as just a character in the name of my instance.Changing + to an ordinary letter the problem disappeared!These problems exist just for breaking our nerves!Anyway dude,thanks for your answer to my question.
 

You're welcome. May be they fixed it in IC6131, because in ic610 it was a definite discrepancy with that "/". Anyway, glad you solved your problem.
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Back
Top