Continue to Site

Welcome to

Welcome to our site! is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

wavecom modem gprs help

Not open for further replies.


Full Member level 5
Nov 15, 2008
Reaction score
Trophy points
Activity points

I am trying to connect to GPRS through HyperTerminal using AT commands
with wavecom modem herin what i've done, :
~ }#À!}!} } }2}#}$À#}!}$}%Ü}"}&} }*} } g}%~~ }#À!}!} } }2}#}$À#}!}$}%Ü}"}&} }
after it types "CONNECT" I receive this garbage and the hyper terminal
stucks - until I disconnect the modem manually, Why does the hyper
terminal stuck?
(I want to send data from my application to the internet, or I want to
access the internet from through hyperterminal)How can I access the internet?

dont disconnect the modem when it is under communication, you will end up spoiling the modem on repeated doings... hyperterminal cannot show webpage...

copy these special charaters into notepad and save as .htm and open in internet explorer... you will see the message hidden in the special characters...
thanks ckshivaram for your response
i tried coping the special character and pasting them in a file and name it .htm, when i open it i see the same characters, no change :(

so i have setup dial up connection in windows and now i am trying to connect to internet using wavecom modem. i successfully get authenticated and i am connected to the network, but when i try to open any website it doesn't load and i get error "server not found". if i use ipconfig command at command prompt i can see ip address is assigned to the connection. when i put the same sim card in my phone i can browse internet through it.
any suggestion would be helpful

you have to open in internet explorer , not in note pad.............

---------- Post added at 08:27 ---------- Previous post was at 08:26 ----------

try to save it as .html and try it........

yes i have checked it in both firefox and IE same result.

do you know how to change imei of wavecom modem? actually, after trying for several hours i realized that i am not able to register on network itself (light is stable and does not blink) and for it i suspect imei problem. i checked imei of the module and it returned 012345678901234 is it possible that my service provider have blocked this particular imei number? because earlier i was using the same module for sending SMS and it working perfect and all of a sudden when i started using GPRS I am not able to register on network. I have tried using another service provider's SIM also and still i am unable to register on network. Both the different SIM card are connecting to gprs through mobile phone.


Is your SIM GPRS enabled???? You cannot modify the IMEI number of the modem... See the data sheet or AT command data sheet of the wavecom..........

~ }#À!}!} } }2}#}$À#}!}$}%Ü}"}&} }*} } g}%~~ }#À!}!} } }2}#}$À#}!}$}%Ü}"}&} }
It's plain PPP communication, which will be started by the modem with the shown configuration after succesfully connecting to a GPRS access point. Neither Hyperterminal nor Internet Explorer will understand it.

As a more general comment, I 've answered basically the same question in similar threads (not particularly related to Wavecom but other GPRS modems) several times during the last weeks, and many other edaboard users did before. I think, there should be enough stuff to find the answer by using the edaboard search feature.

P.S.: As far as I'm aware of, newer Wavecom GPRS modem are exposing a proprietary TCP/IP AT command set, that allows to connect TCP without implementing a PPP-stack, as other vendors also do. But i don't use present Wavecom modems and don't have a documentation. Check it yourself.
Last edited:

ok, so now i am stuck. i bought these modules thinking that they would work right out of the box, but now none of the module is working because of imei. gsm service providers have blocked that particular imei.

searching for changing imei number i came across an application DWLWIN, can some one tell me how to use that application to change imei, i tried but its not reading module? if i can change imei number i hope modules will work. i talked to the seller about it and he's asking me to pay 150$ for it :(
imei number in wavecom modules are stored in eeprom so it can be erased and a new can be setup.

ckshivaram, from where do you buy wavecom modules? can you point me to some online seller?


I don't understand the IMEI point. It sounds completely speculative. At least the problem reported in your initial post seems not related to it. Because the GPRS modem was apperently correctly connecting to the network, but you didn't manage to communicate through PPP.

But you can try with a SIM card for a different network.

i agree, earlier it was working. i have multiple wavecom modules, all of them suddenly stopped registering to network. i have tried it with other sim cards of different network also, but still its not working. If i use the same sim card with other brand of gsm module then i get registered on network.

The only difference which i can think between wavecom and other brand module is imei number, all the wavecom modules have imei 012345678901234 and other brand module have a different and valid imei

may be i am completely wrong but why is it so that all of a sudden wavecom modules stopped working and other brand module is working. also recently i came to know that GSM service providers in India will be banning devices which will not have a valid IMEI.

i came to know that GSM service providers in India will be banning devices which will not have a valid IMEI.
Yes, that sounds reasonable. Also the fact, that has been most likely used by other devices from the same dubious source at the same time. I didn't notice before, that it's obviously a fake number.

I don't know where you got the device. I think, that Wavecom may be interested to know about the evidence.

yes , i too agree with FvM... this sounds like a fake or invalid number.... every device should have a unique IMEI number which is not there in chinese phones and modems....

and changing the IMEI number wont solve the problem as it might be conflicting the IMEI assigned to other modems.... Sorry to say that my modems had different number........

Its better you contact the wavecom to confirm the modem genuinity.........

i bought these module from a chinese vendor.
now i will not use it instead i'll go with sim900 modules.

is wavecom still active? when i go to it diverts me to

wavecom is acquired by sierrawireless in 2009.. but they retained the brand name wavecom for modems.....

some branches still operate with the same name wavecom... and still produce modems in the same name.........

Hi all,
I have been trying to use the modem to connect to internet, as said above. I was able to do it by application but how can I do it through AT commands? any idea?

I have interfaced gsm modem to atmega 16 to send gps data to a mobile number. Now, i am finding difficulty in sending it to a static ip. I am using a vodafone gprs activated connection. I am sure that i can handle the coding part but i am finding difficulty with the PDP context and APN. Can you please help that from where can i get such information or just the parameters of "AT+CGDCONT" and "AT+CDNSCFG" command's
Thanking You

refer the wavecom data sheet and the TCP connection procedure.....
Sir, I am using a Rhydolabz Gsm modem with a vodafone gprs activated sim. I got the APN from customer care as 'www' . Now, I need DNS servers. can u please help me out how to get these.

Not open for further replies.

Similar threads

Part and Inventory Search

Welcome to