Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

Re-Help regarding lcd driving!!!!!!

Status
Not open for further replies.

mandar_mahajan

Full Member level 2
Joined
Jul 8, 2009
Messages
134
Helped
7
Reputation
14
Reaction score
5
Trophy points
1,298
Location
mumbai
Activity points
2,090
Hello All,
I am facing a serious problem & therefore wanted an immidiate help.

I am driving a 9 segment * 4 backplane with 89lpc936 & a shift register.
My supply voltage for controller is 3V & have kept 1.5v for backplanes.
My problem is that,
when I am putting the data for not glowing any digit as per the attach waveform(attach file), I am getting the dimming effect of the all segments which is unwanted. I am not able to understand how to eliminate this?
 

narindia16

Member level 1
Joined
Aug 4, 2009
Messages
32
Helped
2
Reputation
4
Reaction score
2
Trophy points
1,288
Location
Ambala
Activity points
1,523
Document is not blank........Alothough i don't know the exect problem but from my bit knowlage says.....you should check ur connections.....may be some loose connection or you should check ur SMPS........i know i am telling u very basic things..........but what more i can tell u!!!!!!!
 

Los Frijoles

Full Member level 1
Joined
Oct 5, 2006
Messages
98
Helped
7
Reputation
14
Reaction score
3
Trophy points
1,288
Location
Provo, Utah, United States
Activity points
2,252
To eliminate dimming of segments you need to have a constant current driver. Whenever you switch on a segment you are drawing slightly more current from that segment which will cause your other segments to dim.
 

mandar_mahajan

Full Member level 2
Joined
Jul 8, 2009
Messages
134
Helped
7
Reputation
14
Reaction score
5
Trophy points
1,298
Location
mumbai
Activity points
2,090
Hi All!
The problem which i mentioned is for back-plane no 1 & all the segments which are on back-plane no 1.
I have also checked the DC & AC voltages on all the four back-planes.
1) The DC voltage on all back-planes is same = 1.5V( half of the appilied voltage as they are in tri-state).
2) The AC voltage on back-plane no 2,3,4 is .58miliV & for back-plane no 1 it is .53miliV.
IS IT BECAUSE OF THAT. I MEAN TO SAY THAT SEGMENTS CORROSPONDING TO BP1 AS ALWAYS GLOWING DIMM.

I DONT HAVE A OSCILLOSCOPE HERE WITH ME BUT I AM GOING OTHERPLACE FOR IT. & WILL INFORM U ABOUT THE OBSERVATIONS.
MEANWHILE IF U FOUND OR KNOW ANYTHING ABOUT THE ABOVE MENTIONED, PLZ LET ME KNOW.

& FOR BLUEROOMELECTRONICS, IF U ARE NOT ABLE TO VIEW THE WAVEFORMS HERE IS THE LINK FOR ALL.(look for fig 2 & fig 7).
http://dataweek.co.za/article.aspx?pklArticleId=2382&pklCategoryId=31
 

Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top