Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

[SOLVED] Problem with relay connection

Status
Not open for further replies.

Mrunal Ahirrao

Full Member level 2
Joined
Nov 26, 2012
Messages
133
Helped
2
Reputation
4
Reaction score
2
Trophy points
1,298
Location
India
Activity points
2,213
hi all,
Actually I am making a DTMF based appliance controller. But I am having a problem in Relay. I have used Electromechanical relay. problem is when 8870 gives output to relay it doesn't switched on! So I thought might be current is less provided by 8870. So iadded transistor between relay and IC. but then also its not. When I measured voltage across relay its 1.94V. and when i remove the IC's output to relay and measured on transistor then its 5V and again if I attach relay to transistor then again voltage drops from 5V to 1.94 V! How this is happening? please help.
 

sequel

Member level 4
Joined
Oct 27, 2012
Messages
76
Helped
8
Reputation
16
Reaction score
7
Trophy points
1,288
Location
Nigeria
Activity points
1,753
what is the voltage rating of the relay...i mean the dc rating of the coil. and at what voltage is it being run from.
once the voltage is lower than the relays' rated voltage it will not be sufficient to energize the coil hence your circuit will fail.

you should also have it in mind that 8870's current output is so small...

post your circuit for further trouble shooting.....regards
sequel.
 

Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top