Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

Problem in using flash magic for LPC932

Status
Not open for further replies.

kalpana.aravind

Junior Member level 3
Joined
Jan 13, 2006
Messages
25
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,605
Hi everyone.

I am using a development board (PCA9564 evaluation kit) from Philips Semi (requested online directly from them), and LPC932 is part of the circuit. I had previously managed to do programming and code development on this board. But up to yesterday, strange thing happened, the Flash Magic V2.4 no longer able to connect to the LPC932 anymore. My question is:

Is there a way to check is the LPC932 locked up?(anyway to reset it if it locked up?) Or the uC had exceeded the number of time where the LPC932 can be programmed?

every time when i am trying to start the flash magic after selecting device it displays message "cannot connect, try reducing baud rate'. Don't understand how to connect the flash to download the program.
Anyone faced the same problem using LPC932?

Please help me in this.
Thanks in advance.

Kalpana
 

sunish

Advanced Member level 4
Joined
Sep 4, 2005
Messages
117
Helped
10
Reputation
20
Reaction score
2
Trophy points
1,298
Activity points
2,359
hai
i hope that you made all settings right
then there can be a problem with the controller itself
it happened once with me also
normally it happens when u send the program for interfacing the pc.

regards

sunish
 

bobsanjose

Advanced Member level 1
Joined
Jan 13, 2006
Messages
416
Helped
54
Reputation
108
Reaction score
21
Trophy points
1,298
Location
Silicon Valley
Activity points
5,228
Most likely you did not exceed the maximum programming cycles of >100000 cycles. More likely there was a power fail while you programmed the device and this can generate strange behaviour. Did you check all the information on the website of ESAcademy? This company makes Flash Magic
http://www.esacademy.com/software/flashmagic/fmfree.htm
Hope this helps, Bob
 

rutvik1588

Newbie level 5
Joined
Jun 3, 2010
Messages
8
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,344
i've also used dat flash magic and faced the same error message several times..but one thing i want to direct you about the hardware interfaced with LPC932..make sure that none of the other device is directly connected to Vcc of LPC932..it must be isolated while programming...another thing the flash magic is using ISP mode...so be sure the Reset and also Txd,Rxd pins are isolated......now use the terminal check using flash magic (as given in the menu bar for serial com port over RS-232) write down something and u will get some garbage response. means ur terminal is now communicationg....making all the things sure u need to check the device signture..if u r unable to read the device signature...means ur ISP factory code setting is erased......or u might hve lost ur device.

Hope this will help you
Rutvik
 
Last edited:

nikhilele

Advanced Member level 3
Joined
Jan 11, 2006
Messages
805
Helped
101
Reputation
202
Reaction score
76
Trophy points
1,308
Location
Bangalore India
Activity points
6,375
i faced similar problem:
cannot connect, try reducing baud rate'. cannot connect, try reducing baud rate'.
but that was my problem in my code as my code was transmitted some data on Serial port continuosly and hence flash magic was not able to connect.
luckily i was having some conditions which stopped serial transmission from MCU and then i tried to do programming.. and i got success...
but this wasted my whole day..
 

Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top