Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

Problem in MPLAB with ICD2 made using LM358

Status
Not open for further replies.

xmli1976

Full Member level 1
Joined
Nov 3, 2004
Messages
95
Helped
3
Reputation
6
Reaction score
1
Trophy points
1,288
Activity points
835
I made a icd2 by myself,the schematic is from www.stolz.de.be using LM358.
but it doesn't work.
when connecting this icd2,the output windows display the following results :
Auto-connect not enabled - Not connecting (Try enabling auto-connect on the ICD2 settings pages.)

ICDWarn0034: Please ensure that your system's serial FIFO buffers are disabled.

Connecting to MPLAB ICD 2

ICD0021: Unable to connect with MPLAB ICD 2MPLAB ICD 2 ReadyDownloading Operating System
ICD0021: Unable to connect with MPLAB ICD 2

...Download Operating System FailedICD0029: Connected tool is not an MPLAB ICD 2: Product ID = 0x0 (MPLAB ICD (1))

ICD0082: Failed MPLAB ICD 2 operation

ICDWarn0054: MPLAB IDE has lost communications with the MPLAB ICD 2. Would you like to attempt to reconnect?
Connecting to MPLAB ICD 2

ICD0082: Failed MPLAB ICD 2 operationICD0082: Failed MPLAB ICD 2 operation

ICD0082: Failed MPLAB ICD 2 operation

MPLAB ICD 2 Ready
ICD0082: Failed MPLAB ICD 2 operation

ICDWarn0054: MPLAB IDE has lost communications with the MPLAB ICD 2. Would you like to attempt to reconnect?
Connecting to MPLAB ICD 2
ICDWarn0054: MPLAB IDE has lost communications with the MPLAB ICD 2. Would you like to attempt to reconnect?
ICD0286: Unable to communicate with ICD
Connecting to MPLAB ICD 2

ICD0021: Unable to connect with MPLAB ICD 2

MPLAB ICD 2 Ready
could any help me?

Added after 1 minutes:

I'm using mp lab7.30
 

UroBoros

Advanced Member level 2
Joined
May 5, 2004
Messages
642
Helped
19
Reputation
38
Reaction score
8
Trophy points
1,298
Location
Cochin - India
Activity points
6,457
lm 358 how to connect

Hai

One of my friends has done this ICD ,and he told me that for him it was working only in MPLAB7.1.

Keep this information in mind and verify if possible.

Make sure by any means weather the PIC is really got programmed with the bootloader and is there any incompatability between MPLAB and the hardware and firmware.

from the message it is giving a feel that MPLAB "see" some device but it is not what it expects.

Carefully check version issues!

picstudent
 

ameriq

Junior Member level 3
Joined
Oct 1, 2007
Messages
29
Helped
4
Reputation
8
Reaction score
4
Trophy points
1,283
Location
Pakistan
Activity points
1,487
connected tool is not an mplab icd 2

Hi, I built the same design, and it gave me similar problem. I changed the MCU from 16F877-20 to 16F877A and uploaded the firmware for 16F877A, found on Blueroomelectronics Inchworm kit, you can download it from there.
Its working perfect, everything, including debugging.

Added after 1 minutes:

I may Add here that I am using MPLAB 8 and its working excellent.
 

amiltonrsilva

Newbie level 1
Joined
Nov 2, 2007
Messages
1
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,287
using lm358

Hello,


I had problems with this circuit too.. but it works. Try the ICD661.zip. MPLAB indicate size error with the firmare BL010101.hex and 877A.
Check the MCLR, I am using a clamp circuit from the DTR pin.
Change the settings of the serial COM that you are using to HARDWARE control (use the help of the MPLAB ) and the "FIFO" message will disapear.
I used the MPLAB 7.2.


ARS

"When someone evolve, evolves everything that is around them" - The Alchemist
 

Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top