Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

[SOLVED] Problem getting PIC-MCP-USB programmer to work

Status
Not open for further replies.

qbone

Member level 3
Joined
Jun 2, 2009
Messages
58
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Location
Lyngby, Denmark
Activity points
1,778
Hello guys

I just purchased the PIC-MCP-USB programmer, but I am having alot of trouble getting it to work.
I am using MPLAB v8.85 with HI_TECH PIC C Compiler.

I have installed the latest FT232 drivers from FTDI as they recommend (v.2.08.24).

I go to Programmer -> Select Programmer and choose PICSTART Plus, and then Enable programmer and it enables perfectly.
I then try to verify my program and I get a bunch of errors:

Code:
PICSTART Program\Verify Report
04-Jul-2012, 14:37:52

Device Type: PIC10F220
Address Range 0-fe


Program Memory Errors

Address  Good  Bad

0000:    0025  0000
0001:    0064  0000
0002:    0A03  0000
0003:    0064  0000
0004:    0A05  0000
0005:    09FE  0000
0006:    0526  0000
0007:    0726  0000
0008:    0A0B  0000
0009:    0426  0000
000A:    0A0C  0000
000B:    0526  0000
000C:    0C0D  0000
000D:    0031  0000
000E:    0CFB  0000
000F:    0030  0000
0010:    02F0  0000
0011:    0A10  0000
0012:    02F1  0000
0013:    0A10  0000
0014:    0A15  0000
0015:    0A07  0000
0016:    0C01  0000
0017:    0006  0000
0018:    0800  0000
0019:    0FFF  0000
001A:    0FFF  0000
001B:    0FFF  0000
001C:    0FFF  0000
001D:    0FFF  0000
001E:    0FFF  0000
001F:    0FFF  0000
Any additional errors are not displayed.

When I am verifying the red diode on the programmer light up.

- - - Updated - - -

Oh and I am trying program this code:

Code:
#include <htc.h>

void init(void)
{
	//INITIALIZA PORTS '1' = INPUT, '0' = OUTPUT (GP3 IS INPUT ONLY)
	TRISGPIO	=	0b0001;
}

void main(void)
{
	init();
	GP1 = 1;
	while (1){
		if(GP1 == 1) 
			GP1 = 0;
		else
			GP1 = 1;

		_delay(10000); //DELAY TIME IN MS
	}
}

On to a PIC10F220
 
Last edited:

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top