Continue to Site

Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Peak Detector Not working

omar_Bakheet

Newbie
Joined
Apr 13, 2024
Messages
5
Helped
0
Reputation
0
Reaction score
0
Trophy points
1
Activity points
48
1715352986772.png

I designed this folded cascode to give me a gain of 63 dB and a GBW of 200MHz , I am using this to make the following peak detector
1715353081513.png

The Vpeak signal doesnt seem to be following the input signal ( frequency 20MHz)
 
how are you re-setting or pulling down the capacitor ?

at the moment it can only go up in volts
On cadence, it seems to be discharging but am not sure where, I tried connecting a large resistance in parallel and placing a small bleed current source and the issue remains
 
Hi,

What - in values - is the exact issue?

You need a scope to verify it. And for sure you might see a higher value because of noise and hum .. but you might see lower value because of too weak charging current or too high capacitive coupling from gate.

You need to go into details if you want good answers.

Klaus
 
Failure-to-follow might be from an overloaded output
or bad bias rails or a bad input common mode position
or....

Debug time, not rando wild guess time.
 

LaTeX Commands Quick-Menu:

Similar threads

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Back
Top