Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Out of date shapes prventing artwork generation

Status
Not open for further replies.

Leonard K

Newbie level 6
Joined
Aug 28, 2009
Messages
11
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Location
Ottawa
Activity points
1,369
I have a show stopper of a problem with Allegro PCB v15.5. When I go to generate artwork files, it can't do it and complains that there are "Dynamic Shapes Out of Date".

It gives me the option of "Updating" the out of date shapes, and when I click on the "Update to Smooth" button, the log window in Allegro PCB says "Updating dynamic shape (1 of 1) +5V, Boundary/Layer4 @ (4180.0 6465.0)...", but nothing changes.

If I click on "Out of date shapes" in the Drawing Options dialog, it gives me a list of the problem co-ordinates, including 4180,6465, which it says has "No Etch". I can see the out of date boundary in the layout, but for some reason I cannot delete it.

I can try the same thing in an old version of the layout which complains of a bunch of shapes being out of date. When I click on "Update to Smooth" everything updates which allows generation of the artwork files.

Does anyone have a fix or proper procedure for this problem?

- Leonard K
 

majnoon

Full Member level 5
Joined
Dec 11, 2002
Messages
288
Helped
36
Reputation
72
Reaction score
4
Trophy points
1,298
Activity points
1,623
Turn on Boundary only then work your way from those points that indicates are problematic.
In some cases you have no choice but to delete boundary, hence shape and re-do it.
This is a bug in Allegro for Dynamic shapes.

M
 

Leonard K

Newbie level 6
Joined
Aug 28, 2009
Messages
11
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Location
Ottawa
Activity points
1,369
Hello "M":

I also thought it was a bug, but as soon as I enabled the display of all boundaries I was able to see the offending shape outline (empty and old) and delete it. The complaint was that it had "No Etch". Which was true. It was an old outdated shape outline. I guess I still have to get used to the fact that if I can't see something in Allegro PCB Editor, then I can't edit it.

Thanks for your response,
- Leonard K
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top