Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

my code for using ov6620 has not result a correct image

Status
Not open for further replies.

saman1969

Newbie level 5
Joined
Nov 22, 2012
Messages
8
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,356
Hi, I want to display images on a LCD by using a ov6620 sensor. for this I use a FPGA that receives data from ov6620 and send them to LCD . I can manipulate OV6620’s registers and think all recommended points in its data sheet are considered but the image is not correct . in fact i have a dismal image that means one of the stages of my try is wrong .All communications to LCD is correct because I could get a correct color bar that its data is not provided directly by sensor , but I send its data with use of sensor timing . this means that when I use independent data that are not provided by sensor image has no problem but by using sensor data I have a dismal image ,as well i use correct timing of the sensor . if any one work with this sensor , it is appreciated to help me. thanks
 

KlausST

Super Moderator
Staff member
Joined
Apr 17, 2014
Messages
19,456
Helped
4,300
Reputation
8,605
Reaction score
4,260
Trophy points
1,393
Activity points
129,023
Hi,

What exactely is the error?
How does the picture look like?


Klaus
 

saman1969

Newbie level 5
Joined
Nov 22, 2012
Messages
8
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,356
hi . the image is very vague . if one stand in front of sensor ,it can be determined that it is an image of a person but not clear that who is he or she.
i do not know the error because of having an image but unfortunately a vague image . if i had no image i could analyze error but having a vague image makes the work hard. i my timing is correct because i could have a clear color bar that was supported by sensor timing but with my independent data.
thank you .
 

KlausST

Super Moderator
Staff member
Joined
Apr 17, 2014
Messages
19,456
Helped
4,300
Reputation
8,605
Reaction score
4,260
Trophy points
1,393
Activity points
129,023
Hi,

The forum has the ability to sho images...


Klaus
 

andre_teprom

Super Moderator
Staff member
Joined
Nov 7, 2006
Messages
9,237
Helped
1,151
Reputation
2,321
Reaction score
1,127
Trophy points
1,403
Location
Brazil
Activity points
53,768
The picture that you're describing is an image obtained by a camera whose focusing lens was likely not properly well-adjusted.
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top