Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

[SOLVED] microblaze implementation on fpga,

Status
Not open for further replies.

moein0114

Newbie level 6
Joined
Jul 1, 2015
Messages
11
Helped
0
Reputation
0
Reaction score
0
Trophy points
1
Activity points
92
hi , i want to implement microblaze on fpga , i do the step by step according to this pdf file but only thing i get in an error , does any one know what should i do to make it solved and don't see any error at least in this step ???

Source of hello world tutorial:
https://ece.wpi.edu/~rjduck/Microblaz...orial v5.pdf

i get error when i type in tcl consol : Command>microblaze_mcs_data2mem workspace/hello_world/debug/hello_world.elf

and the error is :
microblaze_mcs_data2mem: Found 1 MicroBlaze MCS core.
microblaze_mcs_data2mem: ERROR: Could not find "workspace/hello_world/debug/hello_world.elf". Please make sure the file exists.



it does exist , but i dont know why ise can't just find it ,


if any body knows whats wrong please tell me .
tnx
 

Attachments

  • Microblaze MCS Tutorial v5_2.pdf
    2.8 MB · Views: 1

std_match

Advanced Member level 4
Joined
Jul 9, 2010
Messages
1,189
Helped
444
Reputation
888
Reaction score
409
Trophy points
1,363
Location
Sweden
Activity points
9,186
There is some confusion about the elf file name in the tutorial. Maybe the command should be "microblaze_mcs_data2mem workspace/hello_world/debug/hello_world_0.elf".
(added "_0" to the elf file name)
 

dpaul

Advanced Member level 4
Joined
Jan 16, 2008
Messages
1,478
Helped
307
Reputation
614
Reaction score
303
Trophy points
1,373
Location
Germany
Activity points
11,064
Put your elf file in a different dir. and then again try to read it from the new location.
The message clearly says that the file does not exist. That means either the file really doesn't exist OR there is some problem in the dir. path leading to the elf file.
I trust the ISE error message more! ;-)
 

ads-ee

Super Moderator
Staff member
Joined
Sep 10, 2013
Messages
7,820
Helped
1,811
Reputation
3,632
Reaction score
1,772
Trophy points
1,393
Location
USA
Activity points
59,025
type pwd in the tcl console, is the workspace directory actually in that current working directory? If not cd to the correct directory that contains the workspace directory or as suggested in post #3 copy the elf file to the directory reported by pwd.
 

moein0114

Newbie level 6
Joined
Jul 1, 2015
Messages
11
Helped
0
Reputation
0
Reaction score
0
Trophy points
1
Activity points
92
i tried what you said , it doesn't make any Differences , i have no idea what to do . it is making me crazy .
do you have any tutorial that can be useful to me .?
 

moein0114

Newbie level 6
Joined
Jul 1, 2015
Messages
11
Helped
0
Reputation
0
Reaction score
0
Trophy points
1
Activity points
92
actually it does exist , when i go to the address that i have , the file exists , but i don't know why ise cand find it , do you have something else that yourself tried on fpga with microblaze? maybe it could help me .
 

moein0114

Newbie level 6
Joined
Jul 1, 2015
Messages
11
Helped
0
Reputation
0
Reaction score
0
Trophy points
1
Activity points
92
i typed what you said to type , i got this message :
E:/project/porojeiekarshenasi/corgenmicroblaze/led

its not my workspace , bot i got this message .
i changed the ,elf file but didn't work again .
what now ? got some thing ? any idea ? :/
 

ads-ee

Super Moderator
Staff member
Joined
Sep 10, 2013
Messages
7,820
Helped
1,811
Reputation
3,632
Reaction score
1,772
Trophy points
1,393
Location
USA
Activity points
59,025
Based on what you originally posted in #1 the elf file should be in this location.
E:/project/porojeiekarshenasi/corgenmicroblaze/led/workspace/hello_world/debug/hello_world.elf

If it isn't there the create the directory and put it there.

If you don't understand how to work with directories in the OS then you should work at learning that first.
 

Status
Not open for further replies.

Similar threads

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top