Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

Mentor ADVance MS simulator

Status
Not open for further replies.

lovanca

Newbie level 6
Joined
Dec 20, 2002
Messages
12
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
28
Hello,

I am currently using ADvance MS to simulate some VHDL-AMS models.
I would like to output some results in an ASCII file. I can do it in the ADvance MS graphical environnement using the Nets window then view>List>Selected nets.
But I would like to be able to do it also in batch mode :

Therefore I wrote a .do file

# Elaboration phase
if [ batch_mode ] {
add log :eek:rder3:dut:*
add list :eek:rder3:dut:*
} else {
view structure
view nets

add wave :eek:rder3:dut:*
}


# Simulation phase
run -all

# End of Simulation
if [ batch_mode ] {
write list output.lst
quit
}

and launch the simulation. Each time I get the same error message :

ADMS> # Error: Internal Error
# Occurred in DUT(CT_IDEAL/ADC_SD_1BIT) at time 0 fs
# #E Error in tcl script file adc_sd_ct.do: No object found matching :eek:rder3:dut:*

But when I use the .do file without the add list command line, It runs and I do not get any trouble.

Any idea on how I could do ?

Lovanca
 

Daneshgar

Junior Member level 2
Joined
Nov 11, 2003
Messages
22
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,283
Location
Iran
Activity points
387
How can get DVance MS evaluation.
I am form Iran.
and mentor garphic dos not gine me link for download.

pleas me link for download ?
 

ser.rif

Newbie
Joined
Jan 16, 2010
Messages
4
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Location
Serbia
Activity points
1,330
Hi,

At the moment I'm working on some vhdl-ams models for multiplexed input sigma-delta adc for simuation, but at the very beging I run on problems with ADVance MS simulator under Mentor Graphics.

So does anyone have expireience with ADVance MS, VHDL-AMS simulator?

I'm using vasim version v4.6_1.1, and when I trie to compile any soure vhdl-ams script (using command: vacom <scrpt_name>.vhd), compalation fails and I get this error:

"gcc installtation error cannot execute 'cc1': No such file or directory".

I dwonloaded latest version of gcc compiler, bat I still get the same error.

If someone run in the similar problem please post solution.

Thanks in advcance.
 

ser.rif

Newbie
Joined
Jan 16, 2010
Messages
4
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Location
Serbia
Activity points
1,330
Hello again,

after some mentor support net exploring, I found solution for mentioned problem about ADVance MS vhdl ams simulator under mentor design kit, so i find it would be useful to share it with you guys. I hope that it will help someone who run on to same problem as I did, so the solution:

Everything that is need to be done is to unset the following system variable in your unix/linux shell/bash script located in your home directory. Simply type

unsetenv GCC_EXEC_PREFIX

Note: of course you need to source shell script after this change.

Basically versions of ADVance MS after 2007 do not relay on gcc compiler any more.
 

Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top