Continue to Site

Welcome to

Welcome to our site! is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

[SOLVED] MAX3232 not transmitting

Not open for further replies.


Newbie level 5
Jan 25, 2017
Reaction score
Trophy points
Activity points
Hi all,

first post here, I have done several projects before but this time I seem to be really stuck, so her I go.

I have a small circuit that is supposed to communicate with a heating device using some kind of infrared optolink. I attached the schematic.

On my first proto I noticed I forgot to add a capacitor between Vcc and ground, so I soldered one on top of the IC. Because I made a soldering error on the first proto (switched ir led and photo transistor) I made a second one.

The issue I am observing is that the circuit is just showing some noise around zero on the TX pin.

While making the second proto I only soldered the MAX3232 and its capacitors. I soldered a blob connecting DOUT1 and RIN1 creating a loop back on TTL level. This worked on the PC, I have an USB-RS232 interface and using RealTerm I read back what I was sending. The scope showed levels of +- 7V on TX. I also checked V+ and V- because I saw (in my opinion) strange things on those pins on the first proto. On the second proto I observed the same. V+ a noisy 5V, V- a high frequency signal below zero, somewhere between 0 an -2 if I recall correctly. I was expecting +7 and -7.

First question: what should I measure on V+ an V-?

Since the loopback test was working I removed the blob and completed the print. To test it I put a spoon underneath so the IR LED reflects back to the phototransistor. This seems to work correctly. Both the green and yellow led blink when I send something from the PC. I also measure a nice 5V with pulses to 0V signal on pin 11 T1IN. I however see only some noise around 0V on the TX pin. Not high, not low, zero?

Second question: what am I missing here, this should be a basic circuit |O

If necessary I can provide scope readings or extra measurements.

Thanks in advance,


Yes, V- pin should be more negative. Seeing near zero at TX pins suggest it's shorted to ground, either on the board or externally. This could explain also too small V- voltage. If there's no short, the driver could be damaged.

Circuit looks basically O.K., display of ground connections is apparently switched of in the layout (copper pour?). So we can't check it.
Just checked, TX is not shorted to ground. That error should have shown when the solder blob was there. Faulty IC should neither be the case since it worked with the blob.

I will now try to connect the floating inputs to ground and see what that gives.

I indeed disabled the groundpoors, attached with them.


I will now try to connect the floating inputs to ground and see what that gives.
You should do for floating T2IN. R2IN has built-in pull-down to ground.

I will now try to connect the floating inputs to ground and see what that gives.
It should be common knowledge NOT to leave (logic) inputs floating (unless stated in the datasheet). Not with this IC, not with any other IC.

Yes, should be, but apparently isn't :-s. I saw a lot of schematics where this isn't done so I didn't bother. Everybody has got to learn, I'm an embedded software engineer, not a hardware designer.

Connected pin 10 DIN2 to ground, no difference.

There seems to be some sort of signal though on the TX pin. It tries but doesn't succeed. The spikes seem to be in line with how the signal should look.


Removed the capacitors and replaced all of the with 10 uF. Everything works fine now.

I tried to measure the capacitors but they seemed to have no capacitance at all?

Not open for further replies.

Part and Inventory Search

Welcome to