Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

How to configure my EDA tool licenses under Linux O/S ??

Status
Not open for further replies.

cin

Junior Member level 3
Joined
Dec 15, 2001
Messages
31
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Location
Cupertino
Activity points
222
Question 1)
How to find the host name of my PC. My login is " root " and I type in " uname -n " command, I got this message: localhost.localdomain. Is this my host name ?

Question 2)
How to modify my bash_profile. Below is my .bash_profile under ./root directory. Any thing wrong with this modification?

# .bash_profile
# Get the aliases and functions
if [ -f ~/.bashrc ]; then
. ~/.bashrc
fi

# User specific environment and startup programs

PATH=$PATH:$HOME/bin:/usr/local/concept/spicevision-2.1/linux21:$PATH
BASH_ENV=$HOME/.bashrc
USERNAME="root"
LM_LICENSE_FILE=1708@root

export USERNAME BASH_ENV PATH

Question 3)
my license is in the following location:
/usr/local/concept/license.dat

when I execute the following command:
/usr/local/concept/flexlm-8.4/linux21/lmutil lmstat

I got the following error message:
error getting status: Can't find licenses

The first 2 lines of my license are:

server root any 1708
daemon dconcept /usr/local/concept/flexlm-8.4/linux21/dconcept
feature ********
feature ********

Any thing wrong with my setting. My license work in windows 2000.

Question 5)
How to configure my license so that server will start whenever I power up my PC. In window 2000, I know I can select "start service at power up" & "use service" in lmtool. How to do this under Linux O/S ?

Any feedback is welcome :)
 

wolfkin

Junior Member level 3
Joined
Jul 8, 2002
Messages
27
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
201
Q1...
A1:
you haven't set this hostname! you can execute ifconfig command to set it or by gui.
this is a good way, in /etc/sysconfig/network, chang the HOSTNAME's value that localhost.localdomain to your-hostname.localdomain.
Q2...
A2:
don't modify the that file that in your home directory, else, only this user can run this program.
in /etc/profile, add this line PATH=$PATH:path_program_bin. note, you must place it ahead the export PATH line.
add this line export LM_LICENSE_FILE=port@hostname. this hostname that you set previous step.
Q3...
A3:
change hostname to you set prervious in server line of license file.
change daemon'path to that real path.
in /etc/rc.local, add this line path-lmgrd/lmgrd -c path-license/license.dat -l path-license/license.log.

now, you can run following command sequence to enjoy it:
export PATH=$PATH:path_program_bin
export LM_LICENSE_FILE=port@hostname
path-lmgrd/lmgrd -c path-license/license.dat
while you see this license message is correct, you may enjoy it.
 

Status
Not open for further replies.

Similar threads

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top