Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

How can I drive my 5x7 led matrix using pic16f877? and the..

Status
Not open for further replies.

programmer143

Newbie level 3
Joined
Sep 10, 2007
Messages
3
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,299
5x7 led matrix circuit

when using my pic simulator. there are outputs. but in implementing my design, there are absolutely no outputs visible. what is the correct way to connect pin 1 of pic16f788? what about pin 11,12,31,and 32? what about pin 13 and 14?:cry:
 

andre_teprom

Super Moderator
Staff member
Joined
Nov 7, 2006
Messages
9,187
Helped
1,141
Reputation
2,301
Reaction score
1,116
Trophy points
1,403
Location
Brazil
Activity points
53,385
led matrix circuit

Hi,

What compiler/IDE are you using ? CCS/MPLAB ?
What simulator are you using ? PROTEUS ?

+++
 

programmer143

Newbie level 3
Joined
Sep 10, 2007
Messages
3
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,299
ccs c led matrix

im using CCS C compiler. i simulated my program using pic simulator ide and the results were good but when i connect it in the actual design (actual circuit) nothing happens, even the pin that was supposedly high has no output
 

andre_teprom

Super Moderator
Staff member
Joined
Nov 7, 2006
Messages
9,187
Helped
1,141
Reputation
2,301
Reaction score
1,116
Trophy points
1,403
Location
Brazil
Activity points
53,385
matriz led ccs compiler

Are you using ICSP programming, or you have to unplug the uC to do it ?

Try post here the circuit you are using. There is no reason to it don't work if you are doing all it correctly, according datasheet.

+++
 

programmer143

Newbie level 3
Joined
Sep 10, 2007
Messages
3
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,299
led matrix with pic16f877a

hey andre! :D my circuit is finally working. (not fully) but there is progress. i think there is problem with my crystal resonator before. anyway thanks for the reply. :D:D:D
 

Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top