Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

help pickit 2 not working

Status
Not open for further replies.

malhi

Newbie level 6
Joined
Nov 13, 2008
Messages
13
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,420
i have connected pickit 2 with explorer 16 development board have pic24fj128ga010
pickit 2 is not detecting the device,i made it manually..
the problen is m not able to write my program on controller the error coming is in attachment

please help me
 

wp100

Advanced Member level 5
Joined
May 15, 2009
Messages
3,056
Helped
883
Reputation
1,781
Reaction score
736
Trophy points
113
Location
Prime Meridian
Activity points
0
Hi,

Think you should go to the Pickit2 menu - Tools, TroubleShoot and follow the diagnostics with a voltmeter - it sounds like you have not connected correctly or have got some other device connected to the programming pins - see the ICSP section of the Pickit2 manual if you have.
 

mvs sarma

Advanced Member level 3
Joined
Apr 23, 2006
Messages
789
Helped
121
Reputation
244
Reaction score
80
Trophy points
1,308
Location
Hyderabad, India.
Activity points
5,580
wp100 said:
Hi,

Think you should go to the Pickit2 menu - Tools, TroubleShoot and follow the diagnostics with a voltmeter - it sounds like you have not connected correctly or have got some other device connected to the programming pins - see the ICSP section of the Pickit2 manual if you have.
i remember to have read somewhere on Microchip forum, that some batch of explorer 16 development boards have ICSP connector marked in reverse. please check in real board tracing the pins going to the chip and re-connect the pickit2 at the appropriate pins.
Hope it serves your need.
 

malhi

Newbie level 6
Joined
Nov 13, 2008
Messages
13
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,420
sir i have tried the same, its not working i am getting the error of ["programming failed at program memory address"]...m not getting it what it means
 

pranam77

Advanced Member level 5
Joined
Apr 22, 2008
Messages
2,786
Helped
552
Reputation
1,102
Reaction score
371
Trophy points
1,363
Location
INDIA
Activity points
16,414
malhi said:
i have connected pickit 2 with explorer 16 development board have pic24fj128ga010. pickit 2 is not detecting the device,i made it manually..
the problen is m not able to write my program on controller the error coming is in attachment . please help me
Is it the Original Pickit2 from Microchip or some clone? Cheers
 

malhi

Newbie level 6
Joined
Nov 13, 2008
Messages
13
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,420
yes sir it is true from microchip
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top