Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

hanging problem with pic 16f876a

Status
Not open for further replies.

BYY

Newbie level 5
Joined
Nov 10, 2011
Messages
10
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,352
hi...
i have made voltage stabilizer and circuit is successfully tested on vero board many times... but when i try the same circuit on pcb it started giving abnormal behavior... sometimes it works fine and sometime not ok.. even if i plucked pic off and then again put it on socket it stops working accordingly... can sumbody help me out.. thanks
 

Tahmid

Advanced Member level 5
Joined
Jun 17, 2008
Messages
4,758
Helped
1,791
Reputation
3,574
Reaction score
1,650
Trophy points
1,393
Location
Silicon Valley, California, USA (from Dhaka, Bangl
Activity points
30,545
Could be because you might have a problem in the PCB. Did you check the PCB correctly? It could also be due to noise and EMI from surrounding components. Did you filter the power lines? Do you have bypass capacitors on the PIC power lines?
 

BYY

Newbie level 5
Joined
Nov 10, 2011
Messages
10
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,352
yes i have check it. pcb is ok because some tym it works perfectly... yes i hav used .o1 decoupling capacitor and reverse biased diode on pow supply of pic.. now m not getting where the problem is..
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top