Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

Altium spice model simulation

Status
Not open for further replies.

joanna_seczkowska

Newbie level 6
Joined
Nov 11, 2004
Messages
13
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
112
I have imported LT op amp simulation sub circuit model from LTSpice library (.mod) file. I did it by simply changing ext from .mod to ckt.
Altium Accepted this model.
However when it came to simulation it looks Altium does not understand SPICE.
The line which cause error:

ESHD1 88 0 Value={0.5+0.5*TANH(-5*(1.2-V(3,7)))}

I finally figured out that Value in Altium should be replaced by V=( and modified above to the following:

ESHD1 88 0 V=0.5+0.5*TANH(-5*(1.2-V(3,7)))

But now Altium don't understand '*' sign in TANH(-5* ....)

Does anyone has any Hint what is going on?

Robert

Added after 1 hours 4 minutes:

Below lines are from Altium docoment which claims to support below syntax:
Voltage-Controlled Voltage/Current Source
The following general PSpice model forms are supported:
• E<name> <(+) node> <(-) node> VALUE = { <expression> }
 

Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top