Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Again DS89C450-k00 problem

Status
Not open for further replies.

fireball003

Full Member level 3
Joined
Oct 28, 2005
Messages
181
Helped
8
Reputation
16
Reaction score
3
Trophy points
1,298
Activity points
3,157
When I connect my DS89C450-k00 board with my AC-DC adapter then after 3/4 seconds the 5v Vcc becomes 1.29v. I tried 5 different adapters with different voltage and current.But got no solution. There is a voltage regulator on board.

And not to mention that my PC doesn't get this board.

Why is that? How to come out from this problem?

Thanks in advance.
 

IanP

Advanced Member level 5
Joined
Oct 5, 2004
Messages
7,942
Helped
2,309
Reputation
4,620
Reaction score
531
Trophy points
1,393
Location
West Coast
Activity points
66,459
Try to performe the following test:
1) remove DS89C450 from its socket and place it on a conductive foam or other conductive material (AL foil, for example) ..
2) plug in power from power adapter and measure voltages:
- unregulated at pin 3 of U1 - you should read voltage 6 - 9Vdc
- regulated at pins 4/5 of U1 - you should read 5Vdc
- regulated at pins 4/5 of U2 - 3.3Vdc
If 5V or 3.3V are not there, remove solder from JP1 and JP2 and measure again ..
Let's see what you have so far ..
Regards,
IanP
 

fireball003

Full Member level 3
Joined
Oct 28, 2005
Messages
181
Helped
8
Reputation
16
Reaction score
3
Trophy points
1,298
Activity points
3,157
Thank you IanP for your help.

I did what you told. But got nothing. I removed the DS89C450 and then connected the power adapter. As there is Vcc 5v, 3.3v and gnd available onboard, so I measured those voltages. And those remain same. Then I measured the voltage of the pins. There, 1-4 pins have no voltage, from pin 5 the voltage is 1.32 as the Vcc 5 has. The Vcc (40th pin) shows the same.

I need to mention that 3.3v is working fine (shows 3.28v). The problem is only with the Vcc 5v.

I expect your help indeed.

Added after 50 minutes:

Oppsss...
Sorry. I didn't reply to your questions. The answers are-

- unregulated at pin 3 of U1 - you should read voltage 6 - 9Vdc?
==> its 6.07 v

- regulated at pins 4/5 of U1 - you should read 5Vdc?
==> its 1.21 volt like Vcc 5volt

- regulated at pins 4/5 of U2 - 3.3Vdc?
==> it's 3.28 volt.

Waiting for your suggestion.
Thank you
 

IanP

Advanced Member level 5
Joined
Oct 5, 2004
Messages
7,942
Helped
2,309
Reputation
4,620
Reaction score
531
Trophy points
1,393
Location
West Coast
Activity points
66,459
I would like you to further test the 5V voltage regulator:
still with the DS89C450 out of the board, could you connect a 20-25Ω resistor between +5V and GND, and measure this voltage again ..
This test should ensure that the voltage regulator can deliver 5V at 200-250mA ..

Regards,
IanP

Put on hold all of the above: I have just seen section that you added later..
So, what exactly do you read at pins 4/5 of U1? 1.21V?
 

fireball003

Full Member level 3
Joined
Oct 28, 2005
Messages
181
Helped
8
Reputation
16
Reaction score
3
Trophy points
1,298
Activity points
3,157
I was changing my adapters and the voltage in pin 4/5 was changing a bit (between 1.21v to 1.35v). Now I fixed an adapter and now the voltage in pin 4/5 is 1.32volt.

I don't have 20-25 ohm resistor in my hand now. So I connected 47 ohm resistor between 5v and gnd. the voltage is same(1.32v) and current is 130 mA.

Thanks.
 

IanP

Advanced Member level 5
Joined
Oct 5, 2004
Messages
7,942
Helped
2,309
Reputation
4,620
Reaction score
531
Trophy points
1,393
Location
West Coast
Activity points
66,459
You see, 47Ω at 1.32 should draw ≈28mA, so the current is going somewhere ..
Still without DS89, could you check two things:
1) what is the temperature of the voltage regulator; is it hot?
2) remove solder from solder jumper J1 and measure voltage at pins 4/5

We/you have to find the reason why the Vcc5 is incorrect ..

Regards,
IanP
 

fireball003

Full Member level 3
Joined
Oct 28, 2005
Messages
181
Helped
8
Reputation
16
Reaction score
3
Trophy points
1,298
Activity points
3,157
Thanks a lot for your great help.

The regulator is not too hot, but a bit warm.

I am a newbie, not that much experienced. I am afraid of removing solder , because later I may not solder perfectly.

Would you please suggest other options?
Thank you.
 

IanP

Advanced Member level 5
Joined
Oct 5, 2004
Messages
7,942
Helped
2,309
Reputation
4,620
Reaction score
531
Trophy points
1,393
Location
West Coast
Activity points
66,459
Don't be afraid !!!
The purpose of this jumper is to test this circuit section by section, and this is what we are trying to do ..
So, cut, remove, or whatever you think you can do, but open this link .. and measure voltage at pins 4/5 ..

Regards,
IanP
 

fireball003

Full Member level 3
Joined
Oct 28, 2005
Messages
181
Helped
8
Reputation
16
Reaction score
3
Trophy points
1,298
Activity points
3,157
Do you have DS89C450-k00 board? I mean if you have , then I can ask you easily; I wouldn't have to explain a lot.

I can see two solders on the top of the board. One of them is connected with 3.3v and another with 5 v. Other side of the link is connected with another stuff unknown to me (22 10v is written on it).

Will I remove the solder between 5v regulator and that stuff?
 

IanP

Advanced Member level 5
Joined
Oct 5, 2004
Messages
7,942
Helped
2,309
Reputation
4,620
Reaction score
531
Trophy points
1,393
Location
West Coast
Activity points
66,459
I don't have this board, but I have PDF file with its detailed description, including photo ..
22 10V is 22µF/10V(olt) C2 capacitor ..
JP1 is the jumper I would like you to open ..

Regards,
IanP
 

fireball003

Full Member level 3
Joined
Oct 28, 2005
Messages
181
Helped
8
Reputation
16
Reaction score
3
Trophy points
1,298
Activity points
3,157
I should tell you that I don't have desoldering tool in my hand. I tried by hand and failed to disjoint.

Hah!! becoming frustrated.

Anyother test to do? Else I would have to wait another 20 hours for a desoldering tool. Please suggest me other tests that I can do now.

Thanks.
 

IanP

Advanced Member level 5
Joined
Oct 5, 2004
Messages
7,942
Helped
2,309
Reputation
4,620
Reaction score
531
Trophy points
1,393
Location
West Coast
Activity points
66,459
Be patient !!!
You must be sure that the PCB has the correct supply voltage ..
Without +5V present there is no point of testing anything else ..

You can get desoldering tool, such as solder suckers, or desoldering guns, but other option is to use desoldering braid - you should have it in your tool-box at all times - it is very usefull, and won't cost you an arm and a leg ..

Regards,
IanP
 

silvio

Advanced Member level 3
Joined
Dec 31, 2001
Messages
716
Helped
105
Reputation
210
Reaction score
16
Trophy points
1,298
Location
Romania
Activity points
11,497
fireball003 said:
I was changing my adapters and the voltage in pin 4/5 was changing a bit (between 1.21v to 1.35v). Now I fixed an adapter and now the voltage in pin 4/5 is 1.32volt.

I don't have 20-25 ohm resistor in my hand now. So I connected 47 ohm resistor between 5v and gnd. the voltage is same(1.32v) and current is 130 mA.

If the current across the 47R resistor is 130mA then definitely the voltage is not 1.32v (hope your DVM is calibrated).
If you use another DVM in order to read the voltage across the resistor when you measure the current of 130mA with the second DVM, then you can see that voltage are closer to the output of your AC-DC adaptor.
Otherwise, I can't see 100mA coming from your hand into DVM probes when current is measured through 47R resistor.

What's weird is the 1,21V measured first time which is exactly the internal voltage reference. Like the internal R1 = 0 with voltage on SET pin lower than 65mV

Just a presumption, though you can ask why MAX1659 and not MAX1658, too.
Are you sure that your first used power adapter has a DC output ?
Or did you use one with AC output, then you figure out and changed with a proper DC one?
It's true that one of the MAX1659 features is reverse battery protection allowed down to -17v.
But in the same time don't provides reverse current protection. If Vout is greater than Vin by more than 300mV, reverse current will flow.
 

philmod

Newbie level 4
Joined
Jan 14, 2006
Messages
5
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,320
If you are suppling just 5 volts to the board and there is also a 5v reg on the DS89C450 then it will not work, you need to suppling about 7 or more volts to the your board.
 

fireball003

Full Member level 3
Joined
Oct 28, 2005
Messages
181
Helped
8
Reputation
16
Reaction score
3
Trophy points
1,298
Activity points
3,157
What on Earth is going on???!!!?!!?!

Damn I am!! You know what I did??!? I used an AC adapter with my DS89C450-k00 kit!!!

I had no spare adapter. So, I used the 9v adapter what was with my Creative SBS515 speaker. I didn't have any multimeter then. Now while I was checking my adapters again, I found my great stupidity...

Silvio was right!!

Now please tell me what would I do? Do I need to change MAX1659?? How would I test whather it is gone or not?

Is the whole board gone? or only the voltage regulator (MAX1659)?

Please help me!!
 

silvio

Advanced Member level 3
Joined
Dec 31, 2001
Messages
716
Helped
105
Reputation
210
Reaction score
16
Trophy points
1,298
Location
Romania
Activity points
11,497
As IanP said : Be patient !

I believe that only MAX1659 is damaged. It's easy to remove the MAX1659 if you have the proper tools.
But the easiest solution is to remove solder jumper J1 and use an ordinary and cheap 7805 regulator with his output tied to TP7 Vcc5.

It's the quick and less expensive solution.
 

fireball003

Full Member level 3
Joined
Oct 28, 2005
Messages
181
Helped
8
Reputation
16
Reaction score
3
Trophy points
1,298
Activity points
3,157
But how would I limit the current ?
I have made a DC adapter but it has 1000mA output. Will it not be harmful?

Would I solder this Adapter directly with the JP1 ? Or I need to limit the current?

In fact I am afraid of desoldering and soldering that tiny SO package. So please tell me in details how to add a power supply to 5v and 3.3v ?

Thank a lot.

Added after 5 minutes:

I got in datasheet that both MAX1658 and MAX1659 delivers 350mA current. Now if I solder 5v 1000mA current to JP1 to deliver 5v, then will it be harmful for the components? Does it matter? What else to do?
 

silvio

Advanced Member level 3
Joined
Dec 31, 2001
Messages
716
Helped
105
Reputation
210
Reaction score
16
Trophy points
1,298
Location
Romania
Activity points
11,497
First of all check if your adapter has a DC output of 5v unpluged from DS89C450-k00 board.
Then try to fit at adaptor output different resistors starting with 10 ohms (watch do not burn your fingers) and measure the output voltage.
If it's +5v regardless the value of resistors then you can count on adapter.

Only and only if the above tests are succesfully go further.
1. Remove the solder jumper JP1 (it's better to remove it even if it's working with JP1 closed)
2. Make a link between TP7 and pin 1 of J1 connector
3. Plug your +5v DC adaptor into J1 connector (watch the polarity)

Don't worry about the 1000mA. The board will suck only what needs. The most important thing is that your DC adaptor to deliver 5v constant for a wide range of currents (0..1000mA)
 

fireball003

Full Member level 3
Joined
Oct 28, 2005
Messages
181
Helped
8
Reputation
16
Reaction score
3
Trophy points
1,298
Activity points
3,157
Ahhh!!!! Great!! You people are really great...

At last I am successful to run my DS89C450-k00 board by adding direct 5v power supply. It's working great.

I am really grateful to you people. Especially my thanks go to IanP and Silvio who helped me a lot to solve this problem.

Best regards.
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top