Continue to Site

Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

ADS LNA Design

Status
Not open for further replies.

Keefe

Newbie level 5
Joined
Sep 7, 2022
Messages
9
Helped
0
Reputation
0
Reaction score
0
Trophy points
1
Activity points
69
Designing an LNA in ADS and using Agilent MGA-72543 s2p file inserted into SnP. Ran initial simulation and received the following error message:
" Warning detected by hpeesofsim during circuit set up. Unable to resolve variable(s) or functions(s) in expression ` Zopt1=zopt(Sopt,PortZ1)' Sopt "
I attached my schematic, the error message and part of the s2p file.. This is my first time using Zopt and I am using Zopt to achieve the minimum noise figure. Does anyone know how I may alleviate this issue?
 

Attachments

  • zoop2.PNG
    zoop2.PNG
    36.1 KB · Views: 143
  • zoop1.PNG
    zoop1.PNG
    21.6 KB · Views: 155
  • zoop3PNG.PNG
    zoop3PNG.PNG
    21.4 KB · Views: 151

To complete this sort of optimum impedance measurement for noise match you need to have the required noise data in the s2p file, which you do, but you also have to have noise simulation enabled in the schematic. Edit the S-parameter controller so that under the Noise Tab the "Calculate noise" option is enabled and then it should work without error.

1662538848283.png


1662539233742.png
 

Thank you for your input. That is how I solved the issue.
 

Status
Not open for further replies.

Similar threads

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Back
Top