Continue to Site

Welcome to

Welcome to our site! is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

A question about CadenceIC5141

Not open for further replies.


Full Member level 5
Sep 7, 2005
Reaction score
Trophy points
Activity points
Hi, all: I count some troubles when I use CandeceIC5141.

I setup CandeceIC5141 in linux system. But when I use "Analog Enviroment", CadenceIC shows:
*error* Unable to establish connection with SacnWave, please exit and re-start the workbench.

I do not know why this error occurs. Help me, please!!!

check your path, assurance the path included the scanwave was setted

Hi, visualart: what is path?can you explain detailed?

It is the direction on the execute files, where the executre files can be finded.
set path = (/ /bin $C@dencepath)

Hi, visualart: what is the mean "set path = (/ /bin $C(at)dencepath) "? can you explian it detailed?

open and edit .cshrc file.
Put "set path = (/ /bin $C(at)dencepath)" in this file.
$C(at)dencepath is directory where Cadence is installed.
You can check it typing "which icfb" in terminal window


I think this will help you out.

plz go through it and let me know if there is any problem.

Error message:

*Error* Unable to initialize Wavescan. Please exit work-bench and try again. If this error persists contact Customer Support.

Problem statement:

You are running IC5141. When starting Analog Design Environment, you noticed the following error message in the CIW: *Error* Unable to initialize Wavescan. Please exit work-bench and try again. If this error persists contact Customer Support.

The software works fine on RH Linux 8.0 and seems to appear on RHEL3.0 workstation, which is supported by Cadence.

You check that the LD_ASSUME_KERNEL is set to 2.4.1. Hierarchy Editor and cdsdoc also error out when invoked on this operating system.

Why are you getting those errors ?


The workaround is to reboot with an additional flag on the boot line, by adding 'noexec=off' to the kernel boot line. This is normally configured via /etc/grub.conf A sample is below. The "WS TEST" configuration is the fixed version.
# grub.conf
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg. # root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/sda6 # initrd /initrd-version.img
title Red Hat Enterprise Linux WS (2.4.21-15.0.2.EL)
root (hd0,0)
kernel /vmlinuz-2.4.21-15.0.2.EL ro root=LABEL=/
initrd /initrd-2.4.21-15.0.2.EL.img
title Red Hat Enterprise Linux WS TEST (2.4.21-15.0.2.EL)
root (hd0,0)
kernel /vmlinuz-2.4.21-15.0.2.EL ro root=LABEL=/ noexec=off
initrd /initrd-2.4.21-15.0.2.EL.img -----------------------------------------------------

When you boot your system, you will see an additional entry for the WS TEST configuration. Make sure you select that entry with the up/down arrow keys and then hit the Enter key.

Once you are satisfied that the workaround fixes the problem, you can change the "default=0" setting in /etc/grub.conf to automatically boot the desired configuration.

Just choose the other wave view options in the Analog Enviroment.

Not open for further replies.

Part and Inventory Search

Welcome to