+ Post New Thread
Results 1 to 5 of 5
  1. #1
    Full Member level 5
    Points: 2,214, Level: 10

    Join Date
    Jul 2015
    Location
    Faridabad India
    Posts
    253
    Helped
    22 / 22
    Points
    2,214
    Level
    10

    Microcontroller pin not working after some time.

    Hello experts
    I made a pcb with pic18f25k20 microcontroller. I programmed it and powered it for few days. After 2 weeks microcontroller pin that connected with 7segment/3digit display dot pin stopped to working.
    In the circuit microcontroller pin connect to 7seg pin with a series resistance 470E. 3.3v power supply for whole circuit.
    3.3/470 = 7ma
    Microcontroller pin capable to carry 25ma according to datasheet. I wonder why this pin stopped to working.

    I will be thankful if you give me some advice about it.

    •   AltAdvertisement

        
       

  2. #2
    Advanced Member level 5
    Points: 25,005, Level: 38
    barry's Avatar
    Join Date
    Mar 2005
    Location
    California, USA
    Posts
    4,790
    Helped
    1061 / 1061
    Points
    25,005
    Level
    38

    Re: Microcontroller pin not working after some time.

    ESD? Over-temperature?



    •   AltAdvertisement

        
       

  3. #3
    Full Member level 5
    Points: 2,214, Level: 10

    Join Date
    Jul 2015
    Location
    Faridabad India
    Posts
    253
    Helped
    22 / 22
    Points
    2,214
    Level
    10

    Re: Microcontroller pin not working after some time.

    Hamm
    May be not protect to every pin from electrostatic discharge. I never seen any additional circuit with 7seg display. It will be best practice if external protection against ESD, EOS etc.

    Second is temperature, that i didn't measure. May be it can be cause of fault. A 0.5va 230 to 12v transformer is present near by controller but not more close.



    •   AltAdvertisement

        
       

  4. #4
    Super Moderator
    Points: 30,261, Level: 42
    andre_teprom's Avatar
    Join Date
    Nov 2006
    Location
    Brazil
    Posts
    9,055
    Helped
    1142 / 1142
    Points
    30,261
    Level
    42
    Blog Entries
    9

    Re: Microcontroller pin not working after some time.

    The current driving the 7-segments display sounds comfortably dimensioned, so it is unlikely that there was a burning problem, except of course due to improper handling when energized; frankly, I believe that the problem lies in programming scope, review the code to check this possibility.
    --------------------------------------------------------------------------------------------------
    Part of the world that you live in, You are the part that you're giving ( Renaissance )



  5. #5
    Advanced Member level 4
    Points: 8,093, Level: 21
    Achievements:
    7 years registered

    Join Date
    Jan 2015
    Posts
    1,136
    Helped
    351 / 351
    Points
    8,093
    Level
    21

    Re: Microcontroller pin not working after some time.

    How did it stop working? What tests did you do to confirm it? (i.e. did you check with a scope, DVM etc.)
    When you powered the device off and (a little later) back on again, did it start working again or is it permanently 'dead'?
    Susan



--[[ ]]--