Continue to Site

Welcome to

Welcome to our site! is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Xilinx CORE Generator bug upgrading a pre 14.3 core?

Not open for further replies.


Full Member level 6
Oct 4, 2012
Reaction score
Trophy points
San Diego
Activity points

I've been trying to upgrade a number of cores produced in 13.3 to the current 14.3 tool suite. I've run into a hitch though where there is a very cryptic message being generated.


I upgraded the 13.3 cores to 14.2, which worked fine, but even after that the cores still won't upgrade to the latest version of the core in 14.3.

So far I've tried this on two Win7 64-bit machines. Haven't tried with the 32-bit tools yet (Spent half the day just installing 14.3 on my laptop besides other work :-x).

I'd like it if someone can verify that they also can't upgrade a 14.2 core to a 14.3 core in CORE Generator just as a sanity check on my results.

It would also be interesting if a Linux user could try this and see if it has the same issue.

FYI. I'm using Block Memory Generator, Distributed Memory Generator, and FIFO Generator cores.


Okay now I'm really at a loss, I've built a testcase of a 13.3 FIFO and then upgraded to 14.3 without a problem. I retried with a file from the real project and it's still broken.

Now what? Anyone seen a problem like this before?


Well I found a way to get around the problem, but the solution makes no sense whatsoever.

It doesn't make a lot of sense, but instead of upgrading and regenerating the cores in my source controlled directory that uses a mapped drive letter. I moved all the .xco files to a temporary test directory which I then created the 14.3 core generator project in. I included each core one by one and upgraded them as I went, which worked.

I have no clue why it didn't work in the first place.



This is actually a bug in the 14.3 core generator tool. I've determined this by going into the tmp directory the tool produces when generating the core and found that the tool is using relative paths for files called out in a .prj file (that is generates on the fly) for the core when run from my C drive. Once I use my source control directory with a mapped drive the tool starts using absolute paths that are pointing to the wrong directory! Looks to me like the script writer screwed up the path extraction in 14.3, which used to work in 14.2.

It's unlikely anyone else would run into this kind of problem, but I figure I might as well document the issue in case someone else runs into this problem. Until Xilinx fixes this the only solution is to run it in a local temporary location, then copy the results back to the source controlled location.


Not open for further replies.

Part and Inventory Search

Welcome to