Continue to Site

Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

XIAOMI Mijia Robot Vacuum Mop 1C (STYTJ01ZHM) - Wheel Stuck

stenzer

Advanced Member level 3
Joined
Oct 1, 2012
Messages
877
Helped
123
Reputation
250
Reaction score
185
Trophy points
1,323
Activity points
9,069
Hi,

my XIAOMI vacuum cleaner robot complained since a while that it's left wheel got stuck although there was no obstacle. He even some kind jumped when I was able to observe this issue. Below a solution for my problem can be found.

First thing I tried was to clean the wheel and the related contacts as recommended here. Everything was quite clean on my side so that did not do the job. So i disassembled the vacuum cleaner, to have a closer look on the electronics, especially everything related to the left wheel driver. Here I could identify the A4950 PWM motor driver. From optical perspective everything looked realy nice and clean. The electrolytic capacitors look fine, but I have not desoldered them to check them. This I avoided because of the conformal coating. The 0.033 Ohm sense resistor (see A4950 datasheet) is fine as well.

So here I suspected a problem with the supply voltage of the A4950 or its reference voltage. To solve the problem, I populated two non installed 0603 capacitors capacitors (470 nF / 50 V) the left wheel (C56 & C58), which are creating a PI-filter with a ferrite bead (region is marked in red below). For the right wheel the layout is somehow nicer and cleaner, and shows an actual ideal PI-filter "layout". For the left wheel the layout is not that nice, and even the smaller capacitor (0402) which was already installed, was farther away from the VBB pin of the A4950. I also installed a 200 µF / 35 V electrolytic capacitor in parallel to the SMD one, as I didn't have a suitable SMD replacement. Further, I installed a wired 100 nF ceramic capcitor to the reference voltage input pin of the A4950. Next to the A4950, a LMV358B from 3PEAK is located, which I assume is creating the required reference voltage. Due to the black solder resist and the conformal coating I did not spend much effort in analyzing the circuitry in detail. The LMV358 at least mentions "it is capable of driving heavy capacitive loads" (nothing more), further the 100 nF capacitor is isolated by a resistor if directly soldered to pin #4 of the A4950.

With this modifications the vacuum cleaner robot has been tested for several hours and it works so far. Before it was "stucked" already after a couple of minutes.

Mainboard_XIAOMI_Mijia_1C_STYTJ01ZHM.png


XIAMO_Caps.jpeg


I hope this information might be of use for someone else.

BR
 
Hi,

the previous solution only worked for about 1,5 months. Two weeks ago suddenly the robot complained again that its left wheel got stucked. I replaced the SMD ectrolytic capacitor as well as the 0.033 Ohm sensing resistor, but this did not solve the issue.

As I was quite reluctand to change the A4950 due to its exposed pad, I changed the motors between the two wheels. It seems this solved the problem (so far). By changing the motors, one has to change the red circled connector board in the image below as well, to provide proper connection. I desoldered it from the board which is directly attached to the motor, so maybe the solder joint was not that stellar anymore, due to slight movements of the motor (but the cables have been kept in place by aglue as well). Or simply the connector board is now sitting tighter in the corresponding counterpart, caused by the rework. I cannot really explain it. The robot was on duty now for about 4 hours without any problems. If in near future the right wheel will make troubles, at least I can point my finger on the motor.

BTW, I removed the two leaded capacitors shown in the post before.

signal-2024-05-23-000719_002.jpeg


BR
 

LaTeX Commands Quick-Menu:

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Back
Top