Continue to Site

Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Transformer shields not connected to anything

Status
Not open for further replies.

cupoftea

Advanced Member level 5
Joined
Jun 13, 2021
Messages
2,668
Helped
54
Reputation
108
Reaction score
116
Trophy points
63
Activity points
14,027
Hi,
We have been given a 500W PFCd Full Bridge to bring up. 115vac, 28vout, 200khz pfc 250khz FullBridge.
The Full Bridge transforner is wound with ECW everywhere.
No margin tape.
They have used copper foil shields between the layers.....(fortunatey these are not shorted turns)
However, they are floating, not connected to anything.
Transformer is 30:6
(15:6:15)
Foil shields between all layers.
Do you agree the foil shields do no good?
 

It is strange that they would be left unconnected, but can't be certain they do "no good" without actually testing with/without the shields.
 
" To be honest, I don't see much advantage on grounding interwindings if the outer foil is already grounded. "

it is to reduce CM propagation.
--- Updated ---

foil shields can aid in moving heat from the middle of the Tx to the outer regions ...
 
Status
Not open for further replies.

Similar threads

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Back
Top