Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

Synopsys 2002.05 Under RH8

Status
Not open for further replies.

mami_hacky

Full Member level 6
Joined
Mar 28, 2002
Messages
337
Helped
18
Reputation
36
Reaction score
11
Trophy points
1,298
Location
Some where
Activity points
3,428
I could not run the main shell script for installing synopsys 2002.05 core synthesis under redhat 8.
when you invoke install.now shell script, it generates some error messages.

any idea?
 

armer

Member level 5
Joined
Mar 29, 2002
Messages
84
Helped
1
Reputation
2
Reaction score
0
Trophy points
1,286
Activity points
576
workshop

I have install successfully before! You have to edit the shell scripts!
 

asichd

Newbie level 6
Joined
Sep 9, 2002
Messages
13
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
17
just comment line 51 & 52 in install.now
 

efundas

Member level 3
Joined
Jul 28, 2001
Messages
62
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Activity points
387
removed the message
 

geconom

Full Member level 3
Joined
Feb 12, 2002
Messages
179
Helped
6
Reputation
12
Reaction score
3
Trophy points
1,298
Activity points
1,464
I am working OK with 2002.05-SP1-3, RH7.3 (+ncurses library). Have you checked that your binaries are compatible with your OS version?
 

efundas

Member level 3
Joined
Jul 28, 2001
Messages
62
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Activity points
387
Removed the message
 

efundas

Member level 3
Joined
Jul 28, 2001
Messages
62
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Activity points
387
Removed the message
 

Dick Hou

Member level 1
Joined
Jul 31, 2001
Messages
40
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Activity points
338
I install 2002.05 under rh8.0 too,and I have set the license file and run GUI ok,but when I read or analyze the vhdl file under doc/examples directory,I always got the internal error, anybody know why?
 

efundas

Member level 3
Joined
Jul 28, 2001
Messages
62
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Activity points
387
Removed the message
 

marsgod

Member level 4
Joined
Mar 3, 2002
Messages
68
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Activity points
405
copy your license file to /usr/synopsys/admin/key,
no need to set the LM_LICENSE_FILE env.
:)
 

brass

Junior Member level 2
Joined
Nov 29, 2002
Messages
20
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
110
i have installed 2002.05, but i can't run the design_v*sion and prime_time's GUI
the system said it couldn't find liborg.so
I want to know how i solve it and where i can find the file
 

roli

Full Member level 5
Joined
Apr 29, 2001
Messages
246
Helped
9
Reputation
20
Reaction score
9
Trophy points
1,298
Location
'SiliconWafer' Island
Activity points
1,824
'design_vision' GUI, and PrimeTime GUI - are not supported well in Linux.

However RH7.3 runs them both, and so does RH8.0.

Starting next year these GUIs will be based on QT - and should be OK.

In the mean time 3 workarounds:
1. Upgrade to either RH7.3 or RH8.0
2. Use 'psyn_gui' rather than 'design_vision' - it is a superset.
3. Use special DC & PT binaries for RH7.2.

I'd personally prefer option 1.
 

brass

Junior Member level 2
Joined
Nov 29, 2002
Messages
20
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
110
oh thank roli, but the os where i installed
the software is RH8.0.
So how do i solve this problem?
 

brass

Junior Member level 2
Joined
Nov 29, 2002
Messages
20
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
110
oh thank roli, but the os where i installed
the software is RH8.0.
how do i solve the problem?
if I still want to use RH8.0.
 

Dick Hou

Member level 1
Joined
Jul 31, 2001
Messages
40
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Activity points
338
Dick Hou said:
I install 2002.05 under rh8.0 too,and I have set the license file and run GUI ok,but when I read or analyze the vhdl file under doc/examples directory,I always got the internal error, anybody know why?
I find that I can run 'design_vision' GUI,it's OK! :eek: :D
but design_analyzer still have the above error.
 

roli

Full Member level 5
Joined
Apr 29, 2001
Messages
246
Helped
9
Reputation
20
Reaction score
9
Trophy points
1,298
Location
'SiliconWafer' Island
Activity points
1,824
There are basically 3 GUI environment/libs available in RH7.2/7.3/8.0:

a. Motif
b. MainWin (MW)
c. QT


Solutions/Info:
1. The old 'design_analyzer' GUI is Motif based - and has never caused any problems for me (RH7.2/7.3/8.0)

2. The new 'design_vision' GUI is MW based, is problematic, and not supported in RH7.2, but runs well on RH7.3/8.0 for some unknown reason.

3. Maybe you should try 'psyn_gui' (the PhyOpt GUI - instead of 'design_vision' GUI) - it is a superset - and runs well on RH7.3/8.0. It is also the 1st Synopsys product in 2002 that is QT based !!!

4. Starting from mid-2003 - all Synopsys GUI products will be QT based !!!

5. PrimeTime GUI currently runs well on RH7.3/8.0.

6. The missing lib (or incompatibel lib) - liborg.so - may be missing depending on RH installation - I have installed Full Server - and had no problems, nor reports on any missing lib.

7. There are interim version Synopsys binaries (see SolvNet for exact download link) - which run the MW based GUIs on RH7.2/7.3/8.0.
 

CatKing

Full Member level 3
Joined
Jun 5, 2001
Messages
157
Helped
3
Reputation
6
Reaction score
2
Trophy points
1,298
Activity points
1,129
roli said:
There are basically 3 GUI environment/libs available in RH7.2/7.3/8.0:

a. Motif
b. MainWin (MW)
c. QT
....
Sorry but what is QT?
I know motif and MW as well, but never heard QT.
 

namelik

Member level 1
Joined
Mar 16, 2002
Messages
41
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Activity points
170
Please go to http://www.trolltech.com ,you can find what

Please go to http://www.trolltech.com ,you can find what is QT ??

and you can download QT GPL/Non-Commercial Version(Qt/X11 Free) to solution some of synopsys GUI problem !!
 

Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top