Continue to Site

Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

[SOLVED] stepper motor drive with 293d

Status
Not open for further replies.

kanni1303

Full Member level 3
Joined
Jun 29, 2012
Messages
164
Helped
12
Reputation
24
Reaction score
11
Trophy points
1,298
Location
Chennai, Tamil Nadu, India
Activity points
2,706
I tried to run my 4 wire bipolar stepper motor with PIC16F877A and L293D driver... but the problem is without any connection to **broken link removed** I get output on all the pins and this makes motor not to rotate... then I checked only 293D **broken link removed** with ordinary dc motor the problem exist again... without anything I connected 5V supply to pin 1,8,9,16 and pin 4,5,12,13 to ground I got 5v across pin 2,3,6,7,10,11,14,15 to gnd... I don’t know what may be problem, where I get these voltages I think there is strong isolation between input pin and output pin and gnd... I tried if there is any internal short but except the ground pins no short was found and it measured 14M ohms across output to gnd... Without giving logic on input the output goes to logic high what may be the problem
 

Without giving logic on input
Unless otherwise specified, logic has only has 2 valid states, high or low. "without" is not a
logic level usually.
Are you inputs tied high, low, or high impedance (which could happen if you've forgotten to
configure the PIC pins as outputs).
They may be floating high. You need to connect your inputs to a high or low logic level.
 
yes i made same mistake... and i didn't connected the common gnd after i use common ground for L293D and PIC it works... thnx for your reply
 

Hi,

Im also connected the 4-wire bipolar motor with L293D driver. I tied all the 4inputs to the ground, and its corresponding output are all shown as Low. While im interfacing the motor with the IC, it got burnt. I dont know why it is happening. Two Ics were burnt. Please clarify me to solve the issue, and please help me to run the bipolar stepper motor.

And i doesnt have any specification for the motor, so i simple given to 24V to drive the motor. and IC operating voltage is 5V.

L293D with motor.png

Regards,
Anboli.C
 

1- Pls chek the current rating of your motor or Change the motor and check again.
 

Yeah I noticed, the current rating was the problem. I changed the motor and checked it. its working.

Thanks for your reply..:)
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Back
Top