Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Smooth Scrolling in moving message problem

Status
Not open for further replies.

microcon555

Advanced Member level 4
Joined
Feb 13, 2009
Messages
109
Helped
9
Reputation
18
Reaction score
5
Trophy points
1,298
Activity points
1,877
Hi everyone

On my moving message display (7x96), while moving the text slowly, i can see the font become thick (i.e. a ghost image of the font) which cant be seen while moving fast.

To avoid this what are the things that should be noted on?
 

engshahrul

Banned
Joined
Apr 27, 2009
Messages
330
Helped
98
Reputation
196
Reaction score
94
Trophy points
1,308
Location
Malaysia
Activity points
0
You need turn-off all LED Matrix before load new next display.
 

madhan7710

Junior Member level 2
Joined
Jun 19, 2007
Messages
20
Helped
1
Reputation
2
Reaction score
0
Trophy points
1,281
Activity points
1,394
Hello All,

Am also facing a situation similar to this thread. My problem is the static display works very nice with good brightness. when i scroll a message that to works very nicely with slightly slanting character which scrolls in very high speed. here also the display brightness is good. Now if try to control the speed by simply repeating the frame for (n) times the message is scrolling slowly but a doubling effect (ghosting) comes and the character scrolls in a straight condition (previously it was scrolling slantingly). What could be the problem? Kindly give some ideas to overcome this issue. Given below are my display details.

Display : 7 x 96
Scanning : Row
Row Drivers : Mosfet
Column Drivers : 16Ch Constant Current Led Drivers
Frame Rate : 65 - 120 hz (i tried to change the frame rate inbetween these limits to overcome my problem but result are same)

for speed control i tried the following 2 methods...

Code:
 for(i=0;i<=speed;i++)
{
for(row=0;row<=7;row++)
{
load column data;
select particular row;

}   
}

Code:
for(row=0;row<=7;row++)
{
for(i=0;i<=speed;i++)
{
load column data;
select particular row;
}   
}

in the first method am getting ghosting effect... in the second method am not getting ghosting effect but led flicking a lot...

If there is no speed control the display works very nicely but very fastly...

Looking for a solution. Thanks in advance.
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top