Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

Sim900 Crashes and Resets

Status
Not open for further replies.

bgurdil

Newbie level 4
Joined
Apr 27, 2011
Messages
6
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,334
Hello Everyone,

I'm using Sim900 GSM module firmware revision B07 and I have a fatal problem with it. Here is the scenario;

I make a call to Sim900 and Sim900 picks up the phone using ATA command. While I'm talking to Sim900 via voice call, I send an SMS to Sim900 (this SMS can be 70 bytes or 170 bytes, does not matter).. Once the message is received by Sim900, Sim900 crashes and restarts. How can I solve this problem?

Has anyone else seen this happen? ...

Thank you,

BG.
 

bgurdil

Newbie level 4
Joined
Apr 27, 2011
Messages
6
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,334
Hi Shivaram,

Thanks for the post.

I'm using Sim900 EVM Evaluation Board and the power supply adapter that comes with the kit.

Any thoughts?
 

bgurdil

Newbie level 4
Joined
Apr 27, 2011
Messages
6
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,334
Thanks for the response,

I tried two different versions, one is:
-1137B06SIM900M64_ST other is
-1137B07SIM900M64_ST....

I'm seeing the same behavior on both firmwares. My Sim300D evaluation board does not have this problem. Has anyone else encountered the reset issue with Sim900?

Thank you.
 

GSM Man

Banned
Joined
Apr 15, 2009
Messages
671
Helped
168
Reputation
338
Reaction score
94
Trophy points
1,308
Location
New Jersey, USA
Activity points
0
Does it crash only when you are connected to a voice call and send an SMS message, or does it crash when you send an SMS message when not connected to a voice call? It doesn't really sound like a power supply issue to me.

The SIM900 has been out for less than a year and there have been several firmware updates - a lot of bug fixes in there. I wouldn't be surprised if you've discovered a bug in the firmware. Do you know if version B07 is the latest firmware release - I believe it was released in December.
 

bgurdil

Newbie level 4
Joined
Apr 27, 2011
Messages
6
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,334
Sorry about the late reply GSM Man... Weekend and other issues got in the way....

First of all, thanks for the reply.

Module does not crash when receiving SMS and Voice call is not present.

Interestingly enough, module also does crash once in a while when GPRS is online and SMS is coming in from the side.

In order to solve the GPRS problem, I send an "AT" command as soon as I see the SMS notification. This solved my problem... however, when voicecall is active, I can't even see the SMS notification, module crashes really quickly...

As far as I know B07 is the latest... I contacted few other people but have not yet heard any definite answers... any comments from anyone else?

This is really frustrating as I know that the operator will be sending 'advertisement' text messages while I'm talking to the user, thus this will cause me to disconnect.
 

GSM Man

Banned
Joined
Apr 15, 2009
Messages
671
Helped
168
Reputation
338
Reaction score
94
Trophy points
1,308
Location
New Jersey, USA
Activity points
0
You may want to contact SIMCom about this and see if it's a known issue.
 

bgurdil

Newbie level 4
Joined
Apr 27, 2011
Messages
6
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,334
I contacted them last Friday and I'm hoping to get a reply back soon...

I'm using the 2Amp power adapter... I don't think the module should require anything higher. My assumption is a network related problem. I even used a li-ion battery that didn't help either...
 

devil6600

Full Member level 5
Joined
Nov 15, 2008
Messages
250
Helped
7
Reputation
14
Reaction score
7
Trophy points
1,298
Activity points
2,931
I contacted them last Friday and I'm hoping to get a reply back soon...

I'm using the 2Amp power adapter... I don't think the module should require anything higher. My assumption is a network related problem. I even used a li-ion battery that didn't help either...
hi bgurdil
were you able to solve the issue. i am also having the same problem with sim900, while connected to gprs and on receiving sms sim900 crashes. if it crashes two or three times then it goes into a state where it does not respond to any at command and does not get switched off using the pwr key, i have to manually remove power and then reconnect it. any advice would be highly appreciated
thanks
 

devil6600

Full Member level 5
Joined
Nov 15, 2008
Messages
250
Helped
7
Reputation
14
Reaction score
7
Trophy points
1,298
Activity points
2,931
thank you ckshivaram for the reply.
i tried the command but it returned error. i'll update my module with the firmware mentioned in the link and then again try that command.
 

devil6600

Full Member level 5
Joined
Nov 15, 2008
Messages
250
Helped
7
Reputation
14
Reaction score
7
Trophy points
1,298
Activity points
2,931
hi ckshivaram,
i updated firmware to 1137B11SIM900M64_ST but still there is problem. it crashes and restarts on receiving sms while connected to gprs.

is there a way to completely disable sms feature?
 

bgurdil

Newbie level 4
Joined
Apr 27, 2011
Messages
6
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,334
hi bgurdil
were you able to solve the issue. i am also having the same problem with sim900, while connected to gprs and on receiving sms sim900 crashes. if it crashes two or three times then it goes into a state where it does not respond to any at command and does not get switched off using the pwr key, i have to manually remove power and then reconnect it. any advice would be highly appreciated
thanks
Hey Guys,

I resolved the issue by contacting the local distributor and eventually getting a firmware update from SimCom. This problem is related directly to the firmware. You will need to contact the reseller at your home country, possibly take some logs using some of the programs they provide and will eventually resolve your RESET problems. I tried around 12 firmware updates before coming to a final "working" firmware.

I wish anyone who is reading this thread lots of luck. One needs to be patient with this module in order to succeed.

Regards,
 

devil6600

Full Member level 5
Joined
Nov 15, 2008
Messages
250
Helped
7
Reputation
14
Reaction score
7
Trophy points
1,298
Activity points
2,931
Hey Guys,

I resolved the issue by contacting the local distributor and eventually getting a firmware update from SimCom. This problem is related directly to the firmware. You will need to contact the reseller at your home country, possibly take some logs using some of the programs they provide and will eventually resolve your RESET problems. I tried around 12 firmware updates before coming to a final "working" firmware.

I wish anyone who is reading this thread lots of luck. One needs to be patient with this module in order to succeed.

Regards,
Hello bgurdil thanks for your response. if its possible then please upload the firmware which resolved your issue.
if you don't mind can you please post/pm contact details of technical person who helped you at simcom.
thank you
 

Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top