Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

SIM300 GSM connection problem

Status
Not open for further replies.

ahtis

Newbie level 1
Joined
Jun 7, 2011
Messages
1
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,291
Hi

We use SIM300 as module in our device. All works 99% fine BUT there are few cases (or locations actually) where the GSM connection downlink seems to "drop" occasionally --> user sends SMS to the device but it never goes there (calls doesn't reach the device either)

Seems that situation gets back to normal when the device sends some SMS to the user. Then all the messsages that user has sent earlier reaches the module and the device replies to those messages also (messages have been waiting "at the cloud").

The downlink seems to drop if there is no data going out.

Have you seen this kind of behaviour with this module and is there something what should be done?
Shouldn't the module keep the connection alive or is there some command which should be sent to network just to be sure?

Processor always sees the modem as "connected to the network".
 

planet69

Member level 2
Joined
Jul 27, 2006
Messages
51
Helped
5
Reputation
10
Reaction score
4
Trophy points
1,288
Location
Malaysia
Activity points
1,551
It seems like sim300 needs resetting periodically. I have encounter failed outgoing calls via sim300 in certain sites and will never recover until device reset.
 

Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top