Continue to Site

Welcome to

Welcome to our site! is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Req. MPLAB C18 help for a beginner

Not open for further replies.


Junior Member level 3
Jul 24, 2001
Reaction score
Trophy points
Activity points
error - could not find file c018i.o.

I'm dooing my first steps with MPLAB C18, with the examples find in the package but I find this error.

Can someone tell me the reason and/or attach a simple working workspace?

Best regards.


Deleting intermediary files... done.
Executing: "C:\Programmi\Microchip\Mcc18\bin\mcc18.exe" -p=18F452 "example1.c" -fo="example1.o" -w2 -ms -Ot- -Ob-
Executing: "C:\Programmi\Microchip\Mcc18\bin\mplink.exe" "18f452.lkr" "E:\SwPic\example1\example1.o" /m"" /o"example1.cof"
MPLINK 3.20, Linker
Copyright (c) 2002 Microchip Technology Inc.
Error - could not find file 'c018i.o'. <------------------------- ????
Errors : 1


error - could not find file c018i.o

Maybe you have use a previous workspace. Delete the workspace, open again the project with mplab and try again. Mplab will generate another workspace.

Best regards,


could not find file c018i.o

Hi Amtalan,

You must fist add the linker script file to the project. Right click on
"Linker Scripts" in the project tree and then hit Add file. Then drill down to
C:\mcc18\lkr\18f452i.lkr to add the file.

Next make sure that all the dir in the "Project\Build Options\Projects" menu are filled in. The last one in that list is the linker script path.

Good Luck


could not find file c018i.o.

Hi all

My project was new, but I bulid a new one following your advices but with the same result.

Here is my poor project, could someone have a look at it?

Best regards.

P.S. its located in C:\software


I met with this issue.But now it is ok.
Maybe you can try according to following steps: project-build option-project-directories-include search path-new-C:\MCC18\h-OK; then project-build option-project-directories-library search path-new-C:\MCC18\lib-OK.
could not find file c018i.o

anniechina, thank you for your thorough followup. Your suggestion fixed my issue right away.

This is something that is really frustrating about the PIC environment. When I start my project I select the C18 compiler tools and my chip (a PIC18Fxxxx) but for some reason the wizard doesn't do the following critically important steps:

1) Include the proper LKR script
2) Include the proper include path
3) Include the proper library path

Under what circumstances would I not need these items? They should, for the sanity of all developers, be included automatically. Without smart users in the community like anniechina I would be dead in the water right now.

In any case, thank you for your words of wisdom. I can finally get started on my project. :)
Thank you all for this information. I've programmed a handful of other 8 bit MCU's and figured PIC should be the way to go and bought the PICkit3. I couldn't find ANY getting started that actually worked - it all appeared to be from the PICkit2 which although it looks identical is very different.

I eventually just downloaded the latest MPLAB and lite version of MCC18. I kept getting compile errors and it was THIS string that helped me figure out I didn't have the directories proper nor did I have the linker set or the H file.

I didn't find ANYTHING in any of the manuals that said I had to do this! You guys got me there. Now I can actually figure out how to flip this LED on!!

hihi Thanks for the insight


I had the same issue. This could happen in two ways. First, you don't have your paths set in Tools location. To do this, goto Project --> Set Language Tools Location, find Microchip C18Toolsuite, expand Default Search Paths(...), and check if you have Include Search Path set to something like C:\MCC18\h, Library Search Path set to something like C:\MCC18\lib and Linker-Script set to something like C:\MCC18\lib (yes, lib too). The first two options (output and intermediate) don't need to be set. Click OK and try it out.
If you came into this situation after you ALREADY made a project work, and now you new project doesn't work, and you are thinking "what the hell..." you are in the second situation. Try this workaround: open a new project with project wizard. Just create a new project, overwrite everything and it's done. It should compile nicely. Don't forget to send an ironic email to Microchip, stating the they are a hardware company, not a software company, so they should leave the software stuff to people who really understand it.
Not open for further replies.

Part and Inventory Search

Welcome to