Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

Query on Auxiliary Converter.

Status
Not open for further replies.

RMADHUSUDHAN

Newbie level 4
Joined
May 21, 2012
Messages
5
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,313
I was testing an Auxiliary Converter having 3 stages: 3 phase half wave rectifier (320VDC o/p), Buck (220VDC o/p) and a Half bridge inverter (+100 -100 square wave, 30 KHz). Used IRFP460 Mosfet as switch for Buck. I rigged up the ckt using a 3 phase, 50Hz dimmerstat and everything was fine till the o/p of rectifier reached 320V. Suddenly some sound came from inverter bulk capacitor and got damaged. **Gate signal was not given to the mosfet**. Mosfet was fine after this. My question is "How can inverter capacitor go bad when mosfet (switch of Buck converter) was off (no gate signal)?
Was this problem due to the absence of gate signal (+15V pulse at 60KHZ)?
Please help me..
 

FvM

Super Moderator
Staff member
Joined
Jan 22, 2008
Messages
47,848
Helped
14,117
Reputation
28,491
Reaction score
12,799
Trophy points
1,393
Location
Bochum, Germany
Activity points
277,727
The circuit isn't clear. Anything connected to the capacitor centerpoint? Capacitors series connection without parallel resistors is said to work up to 160V each, but only if the capacitors are same value and type. Also with parallel resistors, same capacitor value is required.
 

Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top