Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Pspice simulation problem

Status
Not open for further replies.

rg350dxlover

Member level 1
Joined
Jul 15, 2008
Messages
35
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Location
Malaysia
Activity points
1,566
change y axis to db in pspice

Hello. I'm designing a 1st order butterworth filter. I got all the values and the shape of the gain correct. Only problem is that the y-axis scale is just wrong. I mean the scale is in fV. It's supposed to be just V. I don't know what setting I'm supposed to change. Help!! Thanks..
 

LvW

Advanced Member level 5
Joined
May 7, 2008
Messages
5,844
Helped
1,742
Reputation
3,488
Reaction score
1,343
Trophy points
1,393
Location
Germany
Activity points
39,339
rg350dxlover said:
Hello. I'm designing a 1st order butterworth filter. I got all the values and the shape of the gain correct. Only problem is that the y-axis scale is just wrong. I mean the scale is in fV. It's supposed to be just V. I don't know what setting I'm supposed to change. Help!! Thanks..

The problem is not a false scaling of the axis.
Your drawing has an error: You have connected to the negative voltage supply node a positive voltage. Change the sign - and every thing will be OK.
Two comments for a better understanding:
1.) Normally, the y-axis is scaled in dB (better and quicker evaluation of transfer curve shape)
2.) A Butterworth response belongs to orders of 2 or higher. A 1st order filter cannot be split up into several response types.

Regards
 

disney_snoopy

Newbie level 6
Joined
Aug 19, 2009
Messages
14
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Location
MALAYSIA
Activity points
1,364
LvW said:
rg350dxlover said:
Hello. I'm designing a 1st order butterworth filter. I got all the values and the shape of the gain correct. Only problem is that the y-axis scale is just wrong. I mean the scale is in fV. It's supposed to be just V. I don't know what setting I'm supposed to change. Help!! Thanks..

The problem is not a false scaling of the axis.
Your drawing has an error: You have connected to the negative voltage supply node a positive voltage. Change the sign - and every thing will be OK.
Two comments for a better understanding:
1.) Normally, the y-axis is scaled in dB (better and quicker evaluation of transfer curve shape)
2.) A Butterworth response belongs to orders of 2 or higher. A 1st order filter cannot be split up into several response types.

Regards

the comment that LvW comment for the voltage sign i doesnt agree with that as i feel it is correct.
The only thing that im agree is the y-axis of your graph should be in dB not in voltage. no1 use it VOLTAGE.
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top