Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

[SOLVED] problem with show values in ISIM

Status
Not open for further replies.

electronical

Advanced Member level 4
Joined
Nov 4, 2011
Messages
104
Helped
2
Reputation
4
Reaction score
2
Trophy points
1,298
Activity points
1,975
hello,
I have aproblem with ISIM

I have aprogram that the input of it is array of std_logic_vector.
I wrote a testB for it.in this TB I used an array of integer and convert it to std_logic_vector(5 downto 0) ,when I synt it and then use ISIm ,in the ISIM all negative values are shown "37777777767"(in decimal)

I use thesee library
use IEEE.STD_LOGIC_1164.ALL;
use IEEE.std_logic_signed.all;
use ieee.std_logic_arith.all;
use ieee.numeric_std.all;
 

guetguet

Member level 1
Joined
Jul 19, 2012
Messages
41
Helped
3
Reputation
6
Reaction score
3
Trophy points
1,288
Activity points
1,578
Hi,

Can you show you part of your test bench where you convert the array of integer into an array of STD_LOGIC_VECTOR please.
 

TrickyDicky

Advanced Member level 5
Joined
Jun 7, 2010
Messages
7,045
Helped
2,069
Reputation
4,155
Reaction score
2,023
Trophy points
1,393
Activity points
38,825
as a note, you should NOT use std_logic_arith and numeric_std in the same file as they conflict. Numeric_std is the IEEE standard library.
 

Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top