Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

problem in receiving data from gsm modem using avr microcontroller

Status
Not open for further replies.

bagavathi

Member level 3
Joined
Nov 15, 2011
Messages
59
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Location
Tamil Nadu,India
Activity points
1,698
hi friends,
i used avr atmega8 microcontroller & wavecom gsm modem for receiving message . in the code i use receiver interrupt for receiving message . message is not received for interupt but without using interrupt message is received why? help me
 

sathshya

Newbie level 5
Joined
Sep 13, 2012
Messages
10
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,283
Location
Bangalore,India
Activity points
1,345
hi friends,
i used avr atmega8 microcontroller & wavecom gsm modem for receiving message . in the code i use receiver interrupt for receiving message . message is not received for interupt but without using interrupt message is received why? help me
I am also from Tamilnadu India,you assign or enable all interrupt related bits or register flags,check all the register again,and do the work again,if you want to contact me means I will give my mob no.
 

bagavathi

Member level 3
Joined
Nov 15, 2011
Messages
59
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,286
Location
Tamil Nadu,India
Activity points
1,698
thanks for your reply. i check all register and flag that i set are correct . this same codein is worked in old model wavecom gsm modem but new model gsm modem wavecom modem not work for tis same code .
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top