Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

PLEASE NEED SCHEMATIC TO CONNECT DSPIC33fJ64GP310

Status
Not open for further replies.

melike

Newbie level 4
Joined
Sep 26, 2007
Messages
5
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,314
HELLO I AM TRYING TO CONNECT THIS PIC TO THE MPLAB ICD2 FOR IN CIRCUIT PROGRAMING , BUT THE MPLAB IS NOT DETECTING THE CHIP , AND I DONT KNOW WHAT I AM MISSING OF CONNECT . I CONNECTED ALL VDD , ALL VSS , AVSS AND AVDD , VDD CORE TO CAPACITOR OF 22 UF TO GROUND , MCLEAR WITH A PULL UP RESISTOR OF 10K TO VCC , PLEASE IF SOMEONE COULD SEND ME A SCHEMATIC I WILL APPRECIATE . THANK YOU
ABRIL

abril.saenz@gmail.com
 

melike

Newbie level 4
Joined
Sep 26, 2007
Messages
5
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,314
sure i connected PGC and PGD , ground, vcc and MCLR to the connector of the MPLAB IC2 but it is not detecting the chip
 

melike

Newbie level 4
Joined
Sep 26, 2007
Messages
5
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,314
andre_teprom said:
melike,

Your target uC is power supplied ?


it has an independent power supply at 3.3 V. it is not powered by the MPLAB , when i am checking the voltages in the MPLAB (self test) it say everything is fine , is pass the test, but it is not detecting the chip ( warning 020 )
 

melike

Newbie level 4
Joined
Sep 26, 2007
Messages
5
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,314
Not , i am using the MPLAB ICD2 , i just bought it from microchip , what i did mas to solder the DSPIC33fJ64GP310 in a generic board for smt components , i connected to VCC ( 3.3V) pins
2,16,37,46,62 and 86

VSS (gnd) pins 15,36,45,65,75

AVdd --> 3.3 v
AVss---> ground
Vddcore ----- capacitor 22 uf to ground
MCLR----- pull up resistor to vcc of 10k

and the pins of the connector PGD2 ,PGC2 , MCLR, VCC and Ground

and when i connect the MPLAB it say the self test passed but it did not detect the chip ( warning 20 target id device error)
 

funnynypd

Banned
Joined
May 9, 2007
Messages
437
Helped
48
Reputation
100
Reaction score
25
Trophy points
1,308
Location
USA & Canada
Activity points
0
Check the datasheet, you might need to config which pin will be the PGC and PGD on this chip. And the datasheet might tell you the default, let's try default first.
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top