Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

PicKit3 works well only in debug mode - why?

Status
Not open for further replies.

bednyk

Newbie level 4
Joined
Mar 24, 2008
Messages
5
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,309
PicKit3 question

Hi all!

I have recntly bought PICkt3 Debug Express with 44-pin demo board with a PIC18F45k20 microcontroller. I am facing an issue when programing this demo board in release mode - nothing happens. But whenever I am program in in debug mode program is working perfectly good.

Has anyone got similar problem. I was in touch with Microchip guys but haven't received solution to this issue.

BR,
Mike
 

natraj20

Member level 3
Joined
Oct 28, 2010
Messages
65
Helped
3
Reputation
6
Reaction score
3
Trophy points
1,288
Location
Florida
Activity points
1,769
I got an exact opposite problem. I could work only in program mode. Facing problems with the debug mode.

44 pin - PIC 18F47J53

When i try to work in the debug mode, most of the times I get this error message.

PK3Err0040: The target device is not ready for debugging.
Please check your configuration bit settings and program
the device before proceeding.


Sometimes it works and sometimes it does not. I do not know what to do with the configuration bit settings for the debug mode. Is there any difference in setting those bits from the compiler or from the code?? I could not find anything (like the DEBUG bit referred by many controllers) regarding the debugging in the configuration bit registers. Please let me know how to work in the debug mode.

Coming to your problem, What happens when you select the pickit 3 programmer ?? Does it detect the target board ??
 

beckmail

Newbie level 1
Joined
Dec 5, 2010
Messages
1
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Location
Sydney
Activity points
1,285
Hi bednyk
Have you solved this problem? I have exactly the same situation. I too bought a PICkt3 Debug Express with 44-pin demo board with a PIC18F45k20 microcontroller. It works OK in debug mode but nothing in release mode.
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top