Continue to Site

Welcome to

Welcome to our site! is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Nexys 3 board seems to be failing

Not open for further replies.


Junior Member level 2
Jun 19, 2012
Reaction score
Trophy points
Activity points
Hi ,

I am having an issue with my Nexys 3 board. It was working fine then all of a sudden it cannot be programmed using Adept software. It remains at the below message :

===== Digilent Adept =====
Adept System Rev 2.7
Adept Runtime Rev 2.15
Adept Application Rev 2.4.2
Copyright © 2010
Loading board information...

when I try the function : DvmgStartConfigureDevices

It gives me a message : "Device table failed to enumerate"

All I did was to remove the alias in device table ? Can you please advise what could be the problem and how to solve it ? Is this a hardware failure ?

I've encountered several of these series of dev boards with similar issues, mostly due to PCB flexure cracking failure, resulting in connections or solder joint issues.

Although, in your case, as there is not sufficient information to fully diagnose the issue, it certainly could be the result of other factors.


Thanks, I really don't know what more information to add.

Is this possible to fix ? Unfortunately I am not located in the US

I really don't know what more information to add.

First, I would return the dev board back to factory configuration by setting all jumpers/switches appropriately and then test the Adept programming interface once again.

Also, is the factory builtin self test bit image still available to run? If so, running it should provides some possible answers to likely affected components.

Have you tried programming the FPGA device using the JTAG interface and any storage devices via SPI or other appropriate interface?

If you are, then load and run the factory self test using that method.

You will need to determine the specific cause of the issue, whether or not the issue is with a device failure, PCB flexure issue, etc.

If you can determine the issue is likely to due to a bad solder joint, you maybe able to attempt a reflow of effected solder joints or locate any breaks in traces, if they exist.

Is this possible to fix ? Unfortunately I am not located in the US

It's difficult to say with any certainty. I attempted to purchase several used dev boards of this series, many seem to have PCB flexure damage due to the lack of rubber feet supporting the PCB in critical areas. The cause of the PCB flexure damage, seemed to be due to the previous owner's frequent button and switch closures, with an inordinate amount of force, which flexed the PCB, damaging underlying ball solder joints of nearby BGA packaged components. Of course, as I previously mentioned, your situation maybe entirely different, which is why I would recommend programming via JTAG/SPI every possible component and then test connectivity to the other components using the FPGA or JTAG chain in unit test capacity. As many of the components are accessible via the JTAG chain, it would certainly be a good starting point for diagnosing the specific issue.

It's also certainly possible the damage is isolated to the USB connector or the component implementing the USB interface.

  • Like
Reactions: fahum


    Points: 2
    Helpful Answer Positive Rating
I tried programming the FPGA using IMPACT. It was hanging at first but then worked yesterday. After it worked, Adept is working again.
Then I tried to run software, using the DeppPutRegRepeat function, it fails, the board hangs again and the problem is back. Now I cannot even use IMPACT to program it using JTAG (of course I restarted all software and hardware many times).

So basically , JTA chain wasn't accessible, then became accessible, then problem repeated and it's not accessible again.

So basically , JTA chain wasn't accessible, then became accessible, then problem repeated and it's not accessible again.

What you've described has been referred to as a low cycle fatigue solder joint failure or thermally active fatigue solder solder failure which can manifest itself during power/thermal cycling.

The physical description of the issue is most likely a stress fracture/c r a c k involving one of the solder joints of the FPGA, while in a cold state continuity still exists across the fracture/c r a c k. however once the FPGA device and the PCB begin to warm up, warm state, varying degrees of thermal expansion cause shear/stress forces to occur often in opposing directions which results in the loss of the continuity that existed in the cold state.


If this is indeed the case, then reflowing the FPGA solder joints to the PCB maybe the only remedy.

In fact, this situation you described manifested itself in several of the Nexys series boards I encountered. I suspect the additional shear/stress forces due to the constant repeated button and switch pressing may have contributed to this condition, as solder joints under stress due to thermal expansion may more easily fail when additional forces are applied.



    Points: 2
    Helpful Answer Positive Rating
Thanks BigDog,

Let's see what their support says

Not open for further replies.

Part and Inventory Search

Welcome to