Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

How to work on large files in HSPICE?(.tr0 file issue)

Status
Not open for further replies.

SwordFish

Member level 4
Joined
Apr 27, 2002
Messages
76
Helped
4
Reputation
8
Reaction score
1
Trophy points
1,288
Location
Europe
Activity points
525
large file in HSPICE

Hi,
I have a problem with a large file in HSPICE

I must make some simulations for a large circuit (550 transistors) for about 2-3 ms.
From this simulation I need only the "xxx.lis" file. But because I use transient analysis the "xxx.tr0" file is HUGE !!! more than 2GB !!!
The "xxx.lis" file is about 1MB.

How can I convince Hspice not to make the "xxx.tr0" file ??

Because is so large I have problems with the free space on my HDD and Windows have problems when I want to open it.

Thanks for any sugestions.
 

FNK

Member level 3
Joined
Jan 25, 2003
Messages
67
Helped
5
Reputation
10
Reaction score
5
Trophy points
1,288
Activity points
470
There are two ways
1-Restrict your simulation to the specialized region of your interest
2-Decrease the number of simulation points. This can be done by incrementing the step size.

Hope it helps
 

bastos4321

Full Member level 5
Joined
Dec 31, 1999
Messages
264
Helped
27
Reputation
54
Reaction score
6
Trophy points
1,298
Location
space
Activity points
2,240
The best way is to output in *.tr0 file only the required node voltages or currents.

Use:

.options probe
.probe v(node) or i(element)

Check the hspice manual about the options probe.

bastos
 

kmrkushal

Newbie level 4
Joined
Nov 1, 2012
Messages
5
Helped
1
Reputation
2
Reaction score
1
Trophy points
1,283
Activity points
1,313
I am also facing the same problem.
So basically Hspice does not have any knob to stop dumping of waveforms.
I have tried many different knobs(like removing .OPTION POST) but nothing happens and it keeps dumping stuff.

Any more ideas will surely help
 
Status
Not open for further replies.
Toggle Sidebar

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top