Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

[SOLVED] FT232RL, entegrated LDO 3V3 regulator using PROBLEM

Status
Not open for further replies.

elt42at

Newbie level 6
Joined
Mar 26, 2011
Messages
11
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,387
HELLO TO EVERYONE!

I tried to use, BUS POWERED USB to UART with FT232RL. The design is so simple but, MY 3.3V output is over 4.2V. So, i re-solder 3V3 and VCCIO pins from PCB. I measured with AVO meter. The LDO output pin (3V3) is 3,26V. IT is OK! But THE VCCIO pin seems 4.4V!!!!!!

I soldered 3V3 pin to PCB, The VCC which goings to MCU VCC is about 3.3V. IT is ok!

Now, I have to solder the VCCIO pin to use FTDI FT232RL UART module in LVTTL 3.3V. I have to use VCCIO pin :D :D :D

I don't understand that, WHY an input (power input pin) makes the LDO output up to 4.2volt ????

I only use FT232RL pins RX,TX,CTS,RTS and CBUS0 and CBUS1 as RX/TX leds and CBUS2 as MCU reset, and CBUS3 MCU interrupt!!!

Please help me about that! I can't get integrated 3V3 output in the voltage 3.3V when i solder the VCCIO pin. It goings to 4.2V. Free un-soldered VCCIO pin seems over 4.4V. But it is an input pin !!!!

Thanks for your answers!
 

sunil_n

Member level 1
Joined
Oct 15, 2010
Messages
36
Helped
4
Reputation
8
Reaction score
4
Trophy points
1,288
Location
Bangalore/Coimbatore
Activity points
1,454
Hi,
try adding decoupling capacitors(10micro and 0.1micro farad) at the supply and VCCIO pins.looks like there is some noise issues

---------- Post added at 14:32 ---------- Previous post was at 14:16 ----------

HI,

refer the image, vbus is 5v

 

elt42at

Newbie level 6
Joined
Mar 26, 2011
Messages
11
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,387
YES, my schematics like that expect, my 3V3_LDO and VCCIO pins connected together! MY FTDI is working, UART working.... THE PROBLEM IS THAT WHEN VCCIO AND 3V3_OUT together, I measure 4.2V. When i re-solder VCCIO pin, The voltage is 3.25. I see 4.4V on VCCIO pin when it is free!!
 

elt42at

Newbie level 6
Joined
Mar 26, 2011
Messages
11
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,387
Voltage is perfect! I pick-up VCCIO pin to free by re-soldering. The 3V3 is about 3.26V (fix)
I re-solder all pull-up resistors. Also, now there is 4.4V on VCCIO pin :S
 

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top