Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Flexlm license problem! Failed to open the TCP port number

Status
Not open for further replies.

oznz

Newbie level 2
Joined
Oct 7, 2004
Messages
2
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
45
failed to open the tcp port number in the license

When I start up license daemon with lmgrd,
I've got error message like as

" Failed to open the TCP port number in the license. "

Lmgrd and vendor daemon is not runing at same time.

I assume that this is kind of OS problem, I use RHEL 3

have any Ideas?



root@linux01:/boot> cat /home/proj/rfbeam/stm_lic/v10-lic.log
14:54:13 (lmgrd) -----------------------------------------------
14:54:13 (lmgrd) Please Note:
14:54:13 (lmgrd)
14:54:13 (lmgrd) This log is intended for debug purposes only.
14:54:13 (lmgrd) In order to capture accurate license
14:54:13 (lmgrd) usage data into an organized repository,
14:54:13 (lmgrd) please enable report logging. Use Macrovision's
14:54:13 (lmgrd) software license administration solution,
14:54:13 (lmgrd) FLEXnet Manager, to readily gain visibility
14:54:13 (lmgrd) into license usage data and to create
14:54:13 (lmgrd) insightful reports on critical information like
14:54:13 (lmgrd) license availability and usage. FLEXnet Manager
14:54:13 (lmgrd) can be fully automated to run these reports on
14:54:13 (lmgrd) schedule and can be used to track license
14:54:13 (lmgrd) servers and usage across a heterogeneous
14:54:13 (lmgrd) network of servers including Windows NT, Linux
14:54:13 (lmgrd) and UNIX. Contact Macrovision at
14:54:13 (lmgrd) www.macrovision.com for more details on how to
14:54:13 (lmgrd) obtain an evaluation copy of FLEXnet Manager
14:54:13 (lmgrd) for your enterprise.
14:54:13 (lmgrd)
14:54:13 (lmgrd) -----------------------------------------------
14:54:13 (lmgrd)
14:54:13 (lmgrd)
14:54:13 (lmgrd) The license server manager (lmgrd) running as root:
14:54:13 (lmgrd) This is a potential security problem
14:54:13 (lmgrd) and is not recommended.
14:54:13 (lmgrd) Failed to open the TCP port number in the license.

Added after 2 hours 28 minutes:

solve the problem!

LMGRD and Verdor Daemon mismatched! that's why it doesn't work!

I edited LMGRD from V10 to V9.x and then It works fine.
 

hanzhe

Newbie level 2
Joined
Jul 12, 2006
Messages
2
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,288
failed to open tcp port number in the license

Maybe you need set correct port number and insert statement "USE_SERVER" in you license file.
 

guojason

Newbie level 1
Joined
May 23, 2003
Messages
1
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
28
flexlm tcp port

I still meet the problem.
Can anyone help me
 

Shurik

Full Member level 3
Joined
Jul 15, 2004
Messages
167
Helped
16
Reputation
32
Reaction score
4
Trophy points
1,298
Activity points
842
(lmgrd) failed to open any default tcp port

Hi!!!

next line is necessary in license file:
SERVER <Name of server>
You may to write IP address !

name of server is necessary to write in /etc/hosts.

Best regards
 

soway

Member level 3
Joined
Apr 9, 2004
Messages
58
Helped
8
Reputation
16
Reaction score
0
Trophy points
1,286
Location
China,SuZhou
Activity points
410
lmgrd failed to open any default tcp port

if you use the default 27000,it will use from 27001-27009.

You can see your current port be used by:
nmap -sT 127.0.0.1
 

edacw1

Full Member level 4
Joined
Mar 7, 2004
Messages
221
Helped
5
Reputation
10
Reaction score
1
Trophy points
1,298
Activity points
1,187
failed to open any default tcp port

Maybe you start 2 or more licenses on one port.
 

8k-rom

Junior Member level 2
Joined
May 13, 2006
Messages
24
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,458
failed to open tcp port

edacw1 said:
Maybe you start 2 or more licenses on one port.

I just want to say so~
 

yellff

Member level 3
Joined
Apr 13, 2003
Messages
58
Helped
3
Reputation
6
Reaction score
0
Trophy points
1,286
Activity points
286
failed to change flexlm license server

The port can be change.
 

caprio

Newbie level 2
Joined
Jul 17, 2007
Messages
2
Helped
2
Reputation
4
Reaction score
1
Trophy points
1,283
Activity points
1,288
failed to open the tcp port number

How to edit lmgrd's version?
Thanks
 
  • Like
Reactions: HaoLu

    V

    Points: 2
    Helpful Answer Positive Rating

    HaoLu

    Points: 2
    Helpful Answer Positive Rating

lcbrevard

Newbie level 2
Joined
Oct 25, 2007
Messages
2
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Location
San Jose, CA
Activity points
1,308
failed to open tcp port number

I just had this problem and FINALLY discovered that if /etc/hosts is missing the

127.0.0.1 localhost

line, it causes this same symptom even when EVERYTHING else is OK.

The previous person administering the system had removed the localhost line for who-knows-what reason!

OS: CentOS 3.9 (Red Hat Entterprise Linux v3) clone. 32-bit x86 2.4 kernel

SW: Synopsys lmgrd and snpslmd version 10.9.2 (based on lmgrd 10.8.5).

License: Synopsys Milkyway MAP-in program

LCBrevard
San Jose, CA
**broken link removed**
 

omara007

Advanced Member level 4
Joined
Jan 6, 2003
Messages
1,238
Helped
50
Reputation
102
Reaction score
16
Trophy points
1,318
Location
Cairo/Egypt
Activity points
9,738
flexlm default port

edacw1 said:
Maybe you start 2 or more licenses on one port.

How to know if 2 or more licenses are up on the same port ??
 

lovelyic

Junior Member level 2
Joined
Apr 28, 2002
Messages
23
Helped
2
Reputation
4
Reaction score
0
Trophy points
1,281
Activity points
200
failed to open any default tcp port.

you can use lmstat to check the status of runing dameon.

and please check the license file, you should see following fomat:
SERVER hostname hostid port_number
DAEMON daemon_name path_to_daemon_exe
# DO NOT REMOVE THE USE_SERVER LINE
USE_SERVER

you can change the port_number and restart the license server use following command:
lmgrd -c you_lic_file -l log_file

then check the log_file for detail

Hope this will help you.
Thanks!
 

omara007

Advanced Member level 4
Joined
Jan 6, 2003
Messages
1,238
Helped
50
Reputation
102
Reaction score
16
Trophy points
1,318
Location
Cairo/Egypt
Activity points
9,738
flexlm failed to open any default tcp port

lovelyic said:
you can use lmstat to check the status of runing dameon.

and please check the license file, you should see following fomat:
SERVER hostname hostid port_number
DAEMON daemon_name path_to_daemon_exe
# DO NOT REMOVE THE USE_SERVER LINE
USE_SERVER

you can change the port_number and restart the license server use following command:
lmgrd -c you_lic_file -l log_file

then check the log_file for detail

Hope this will help you.
Thanks!


I indeed did that, and when running the lmgrd on the license I got this log file:




Erased !!! - You have been warned for posting illegal info
---------------- TOPIC LOCKED !!! ------------------
.






I tried then running the dc_shell-t, and I got the following error :

Code:
Fatal: Design Compiler is not enabled. (DCSH-1)

I have no idea where is the origin of the problem !! .. the log file looks normal to me except that the last couple of lines with (snmslmd) do have different time stamp that the previous (lmgrd) lines !! ...

Any explaination to what is happening ?
 

lovelyic

Junior Member level 2
Joined
Apr 28, 2002
Messages
23
Helped
2
Reputation
4
Reaction score
0
Trophy points
1,281
Activity points
200
flexlm port number

please set following environment variable before run dc shell, below is the bash sample:
Code:
export LM_LICENSE_FILE=27000@localhost.localdomain 
export SNPSLMD_LICENSE_FILE=27000@localhost.localdomain

where localhost.localdomain is you hostname

please replace the "(at)" with "@"
 

omara007

Advanced Member level 4
Joined
Jan 6, 2003
Messages
1,238
Helped
50
Reputation
102
Reaction score
16
Trophy points
1,318
Location
Cairo/Egypt
Activity points
9,738
default flexlm port

lovelyic said:
please set following environment variable before run dc shell, below is the bash sample:
Code:
export LM_LICENSE_FILE=27000(at)localhost.localdomain 
export SNPSLMD_LICENSE_FILE=27000(at)localhost.localdomain

where localhost.localdomain is you hostname

please replace the "(at)" with "@"

This (at) in my code block is not originally in the file .. this is due to edabaord restriction ..
For example :

xyz@123.com is written like the normal email format .. but I believe it will be shown like this : (at) ..
 

jonyRoyal

Member level 1
Joined
Apr 24, 2006
Messages
40
Helped
7
Reputation
14
Reaction score
4
Trophy points
1,288
Activity points
1,471
lmgrd failed to open the tcp port number

first of all don't run lmgrd with as a root..........check whether you ethernet card is active.........then check for ifconfig which display your ip ....check hostname and mac id in your licenses..........let me know for further ..........
 

omara007

Advanced Member level 4
Joined
Jan 6, 2003
Messages
1,238
Helped
50
Reputation
102
Reaction score
16
Trophy points
1,318
Location
Cairo/Egypt
Activity points
9,738
failed to open tcp port in license

jonnajagadeesh said:
first of all don't run lmgrd with as a root..........check whether you ethernet card is active.........then check for ifconfig which display your ip ....check hostname and mac id in your licenses..........let me know for further ..........

so, what's after checking all these things ? .. just checking ??
 

omara007

Advanced Member level 4
Joined
Jan 6, 2003
Messages
1,238
Helped
50
Reputation
102
Reaction score
16
Trophy points
1,318
Location
Cairo/Egypt
Activity points
9,738
lmgrd port

I'm now getting this new error :


Code:
 3:58:50 (snpslmd) Error - lmgrd refused vendor name list.
This daemon will only serve licenses for the primary vendor.

Given that I have another version of FlexLM installed on my machine because I installed Cadence long ago before I try to install Synopsys .. and the older FlexLM doesn't work with Synopsys so I had to install a newer version ..


Any clue to solving this problem ?
 

arunragavan

Advanced Member level 1
Joined
Jul 1, 2004
Messages
417
Helped
30
Reputation
60
Reaction score
9
Trophy points
1,298
Location
India
Activity points
5,028
lmgrd failed to open tcp port

Hi Omara007,
I am not any problem with PT. But problem comes only in DC. Did you fix this problem?
 

Status
Not open for further replies.

Similar threads

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top