Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronic Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

Register Log in

Delta sigma ADC transient simulation in Spectre

Status
Not open for further replies.

jowong1

Junior Member level 1
Joined
Dec 14, 2006
Messages
18
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,419
zero diagonal found in jacobian

I am running into a problem when I was trying to simulate my DSADC in spectre. The entire system is using ideal components (no transistors, but there are VCVS, R, C) and Verilog models. When I was doing transient sim using "Liberal" setting, for about 60us, it was running fine and giving correct output (noise shaping and all that) but then at about 60us, all of a suddent, there is a "Zero diagonal found in Jacobian at XXXX net and YYYY net". and then the output starts to just oscillate and I cannot figure out why.

One more thing is that my ADC will work ONLY IF I do the transient in "Liberal" setting, if I try to do it in "moderate" or "conservative", then it wont work at all (The output just stays at a constant voltage).

I was wondering if anyone out there can help me with this.......

Thanks
 

meitolake

Full Member level 3
Joined
Oct 7, 2007
Messages
154
Helped
30
Reputation
60
Reaction score
5
Trophy points
1,298
Activity points
1,894
zero diagonal found in jacobian at

Maybe, the components are too ideal. For example, input impedance is infinite, output impedance is zero...
 
Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top