Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

CoolRunner II strange Programming Error

Status
Not open for further replies.

cristivasilache

Junior Member level 3
Joined
Sep 5, 2005
Messages
26
Helped
3
Reputation
6
Reaction score
3
Trophy points
1,283
Activity points
1,466
coolrunner id

Hello to everybody !

I made a design for an XC2C128-VQ100, simulation ok, compiled ok, and when i try to program the chip with impact software, i have a very strange error, "ERROR:iMPACT:1982 - '1' Done bit could not be programmed correctly". As a result, the chip cannot be used anymore at all, if i try to get device ID, it will display that strange message, that many unknown devices are founded.... I use Xilinx Platform cable USB for programming and i tried with both ise 9.1 and 9.2 web editions. I searched the error, but i couldn't find what exactely means, or what can be the cause. I programmed before many devices and i never had this problem.
Any ideea will be usefull for me. Thanks in advance.

crriss...
 

echo47

Advanced Member level 5
Joined
Apr 7, 2002
Messages
3,942
Helped
637
Reputation
1,272
Reaction score
88
Trophy points
1,328
Location
USA
Activity points
33,183
programming coolrunner

"cannot be used anymore" -- Did it work before? Maybe the device got damaged somehow.

Are you sure you configured the JTAG chain correctly in iMPACT? A CoolRunner-II CPLD doesn't have a DONE bit.

Wild guess: If your JTAG chain includes an FPGA with platform flash, try temporarily changing the FPGA's mode pins (M0 M1 M2) from serial to JTAG.

Or maybe this old problem has returned?
https://www.xilinx.com/xlnx/xil_ans_display.jsp?getPagePath=17523

Also, check for glitches (signal integrity) on the JTAG TCK signal. Try iMPACT's Debug -> Chain Integrity Test.
If that's the problem, then simply adding a 100 ohm series resistor may cure it.
 

cristivasilache

Junior Member level 3
Joined
Sep 5, 2005
Messages
26
Helped
3
Reputation
6
Reaction score
3
Trophy points
1,283
Activity points
1,466
impack coolrunner-ii

"cannot be used anymore" -- Did it work before? Maybe the device got damaged somehow.

The devices were brand new, when i saw this error first time, i tried to program the device with another jed file, just for test. i write a simple vhdl code, and with that one there is no problem, can be programmed, read back, get device id, erase blank check. Same device, if i load the jed file with the problems, i try to program, progress bar goes to the end and after that error message is displayed.
On the board there is no other pld than XC2C128, no FPGA, no Config Memory, so cannot be from this. I know that Init and Done are only at FPGA.
I also try to use different cable speed, from 750 KHz to 24 MHz and the result was the same. Power supply level is ok, 1.8V for the core and 3.3V for IO2 and JTAG. On the same board, i tried with XC2C256, different jed file, and is working.

Can be file the jed file wrong ??? Why the CPLD cannot get device ID ? is there any way to disable JTAG without any confirmation ?. Anyway, if JTAG is disabled, the device should still work, but doesn't work...

Thanx...
 

Status
Not open for further replies.

Similar threads

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top