Welcome to EDAboard.com

Welcome to our site! EDAboard.com is an international Electronics Discussion Forum focused on EDA software, circuits, schematics, books, theory, papers, asic, pld, 8051, DSP, Network, RF, Analog Design, PCB, Service Manuals... and a whole lot more! To participate you need to register. Registration is free. Click here to register now.

[SOLVED] Compiling Systemc and System Verilog on Linux

Status
Not open for further replies.

saurabh.jain.1190

Newbie level 2
Joined
Jan 15, 2013
Messages
2
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,306
Ok the installation is getting on my nerves now!

So, I know VHDL, Verilog and now want to learn SystemC + System Verilog (along with their extension i.e TLM, UVM, DPI or PLI , UPF and others like OCI, SDF, IP-XACT, PSL etc)

But taking the babysteps first, earlier I have been working on Xilinx ISE on Windows. But now I have moved to Linux and my expectations have raised, thanks to free distributions and Icarus Verilog.

I already know how to compile a .c file or a .cpp file plus how to make executable shell scripts.
And thanks to Icarus I know how to compile a verilog file with it's testbench using:

Code:
iverilog -o simple.vvp simple.v simple_tb.v

and fetching it's waveform using:

Code:
gtkwave simple.vcd

But now with similar expectations towards the things I want to learn (i.e SystemC, TLM, System Verilog, UVM)

I have downloaded the free and open source- ("systemc-2.3.0.tgz" which is inclusive of TLM 2.0) + ("uvm-1.1c.tar.gz")

Then I have installed them using:

Code:
tar -xzf archive-name.tar.gz
cd archive-name
./configure
make
sudo make install

And now I am struggling to move forward, i.e. what is the command to link these things/libraries together to my system root libraries and with GTKwave so they compile just like Icarus verilog?

Plus, what is the command to compile a SystemC file?

And also how to use this UVM library on SystemC if I can or otherwise is there a package available to extend my Icarus Verilog compiler to be used as System Verilog compiler and then incorporating UVM 1.1c in it!

My demands might sound unrealistic from one end but are actually great explorations for a newbie to ASIC world, as this EDA world is pretty scattered with all these tools which promises it to be standardised with all our IEEE's and yet we face problems of interfacing different methodologies, so ironic.. I wish all these latest IEEE's should come installed on a Linux distribution with all comiling commands mentioned properly and that too in a Live DVD release within every 6 months duration and that too for free... seriously, then this world can definitely achieve the new heights of technological developments!

I look forward to hear from our EDA friends soon...
 

saurabh.jain.1190

Newbie level 2
Joined
Jan 15, 2013
Messages
2
Helped
0
Reputation
0
Reaction score
0
Trophy points
1,281
Activity points
1,306
Ok finally I have been able to compile SystemC file with the comand:
Code:
g++ -I /home/dell/systemc-2.3.0/include/ -L /home/dell/systemc-2.3.0/lib-linux/ -lsystemc -o sim systemc.cpp

thanks to google, but now I have the following error:

Code:
./sim: error while loading shared libraries: libsystemc-2.3.0.so: cannot open shared object file: No such file or directory

Also I tried changing permissions of libsystemc-2.3.0.so which are presently -rwxr-xr-x but it doesn't allow me and says:

Code:
$ chmod 777 libsystemc-2.3.0.so 
chmod: changing permissions of `libsystemc-2.3.0.so': Operation not permitted
 
Last edited:

Status
Not open for further replies.

Part and Inventory Search

Welcome to EDABoard.com

Sponsor

Top